Product Sales Report Cells Contain "Unknown" (320895)



The information in this article applies to:

  • Microsoft Commerce Server 2000

This article was previously published under Q320895

SYMPTOMS

When you run the Product Sales report, and at least one product variant has been defined and bought, cells such as "Catalog Name" or "Product Name" may contain "unknown".

CAUSE

The Product unique ID and the Product variant unique ID are set to be the same field.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix should have the following file attributes or later:
Date         Time   Version            Size    File name 
-------------------------------------------------------------- 
20-May-2002  20:30  4.0.3050.0        536,848  Cdtstasks.dll
				

WORKAROUND

To work around this problem, change either the Product unique ID or the Product variant unique ID for each catalog so that these values are different. To do this, follow these steps:

NOTE: You cannot change these values by using the Business Desk (BizDesk).
  1. Export the catalog as XML, and then use the BizDesk to delete the existing catalog.
  2. Edit the XML catalog. Change the values for the productUID and variantUID attributes in the catalog tag.
  3. Import the XML catalog.
  4. Use BizDesk to publish the catalog.
  5. Run the Catalog Import DTS task in Full mode, and then run the Report Preparation DTS task in Full mode.

STATUS

Microsoft has confirmed that this is a problem in Microsoft Commerce Server 2000.

MORE INFORMATION

This problem is catalog-specific.

Steps to Reproduce the Behavior

Follow the instructions from the Commerce Server online help to create a new catalog. Make sure that you select the same field for Product unique ID and Product variant unique ID.

Modification Type:MinorLast Reviewed:10/11/2005
Keywords:kbHotfixServer kbQFE kbbug kbpending KB320895