Chkdsk.exe Is Scheduled After You Run Disk Defragmenter on Your NTFS Partition (320866)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional

This article was previously published under Q320866

SYMPTOMS

After you run Disk Defragmenter on your New Technology File System (NTFS) partition, Chkdsk.exe may be scheduled to run the next time you restart your computer. However, Autochk/Chkdsk may not find a problem with the volume. If you again run Disk Defragmenter on your NTFS partition, Chkdsk.exe may again be scheduled to run the next time you restart your computer. The System Event log may contain the following error event:
Event Type: Error
Event Source: Ntfs
Event Category: Disk
Event ID: 55
Date: date
Time: time
User: N/A
Computer: computer name
Description: The file system structure on the disk is corrupt and unusable. Please run the chkdsk utility on the volume F:.

CAUSE

This problem may be caused by a condition in the Windows 2000 Disk Defragmenter tool that may prevent a particular cluster of data from being optimized. When the Windows 2000 Disk Defragmenter tool cannot move a particular data element, the move is stopped, an error is logged in the system Event log, and Chkdsk.exe is scheduled. There is no loss of data, and in this particular condition, the integrity of the data is alright. The errors are a FALSE POSITIVE FOR DATA CORRUPTION.

RESOLUTION

This problem was first resolved in Microsoft Windows XP and Microsoft Windows Server 2003. To resolve this problem, upgrade to the appropriate operating system:
  • If you are using Windows 2000 Professional, upgrade to Windows XP Professional.
  • If you are using Windows 2000 Server, upgrade to Windows Server 2003 Standard Edition.
  • If you are using Windows 2000 Advanced Server, upgrade to Windows Server 2003 Enterprise Edition.
  • If you are using Windows 2000 Datacenter Edition, upgrade to Windows Server 2003 Datacenter Edition.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was corrected in Windows XP.

MORE INFORMATION

To try to work around this problem, use any of the following methods.
  • Run Disk Cleanup on the volume, and then run Disk Defragmenter on the volume again.
  • Back up the data on the volume, reformat the volume, and then restore the data.
  • Move the drive that contains the volume to a Windows XP-based computer, and then defragment the drive.
  • If you are able isolate the folder that is causing the problem, you can try the following procedure:
    1. Make a copy of the folder on the same volume or on a different volume.
    2. Delete the original folder.
    3. Copy the backup copy of the original folder you made in step 1 back to the original location and folder name.
    4. Run Disk Defragmenter.

Modification Type:MajorLast Reviewed:9/22/2003
Keywords:kbenv kberrmsg kbprb w2000defrag w2000fs KB320866