OL2000: An Invalid Page Fault Occurs in the Outllib.dll Module If You Customize the Standard Toolbar in Outlook (320856)



The information in this article applies to:

  • Microsoft Outlook 2000

This article was previously published under Q320856

SYMPTOMS

If you try to customize the Standard toolbar in Microsoft Outlook 2000, you may receive an error message similar to the following:
This program has performed an illegal operation and will be shut down.

If the problem persists, contact the program vendor.
If you click Details, you may receive the following error message:
OUTLOOK caused an invalid page fault in module OUTLLIB.DLL.

CAUSE

This problem may occur if the Outlook 2000 user e-mail profile is damaged.

RESOLUTION

To resolve this problem, re-create the Outlook user e-mail profile.

NOTE: If you turned on the Outlook e-mail service option Internet Only, you must first reconfigure Outlook to use the Corporate or Workgroup option to implement a new user e-mail profile.

To reconfigure Outlook with the Corporate or Workgroup option, and to re-create an Outlook e-mail profile, follow these steps:

Part 1: Change to the "Corporate or Workgroup" Installation

  1. Start Outlook.
  2. On the Tools menu, click Options.
  3. Click the Mail Delivery tab, and then click Reconfigure Mail Support.
  4. On the E-mail Service Options page, click Corporate or Workgroup, and then click Next.
  5. Follow the on-screen instructions to reconfigure Outlook e-mail support.

Part 2: Re-create an Outlook Profile

NOTE: Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.
  1. If Outlook is running, click Exit and Log Off on the File menu.
  2. Click Start, point to Settings, and then click Control Panel.
  3. In Control Panel, double-click the Mail or the Mail and Fax icon.
  4. On the Services tab, click Show Profiles.
  5. Click Add to start the Microsoft Outlook Setup Wizard.
  6. Click to select the check boxes of the information services that you want, and then click Next.
  7. In the Profile Name box, type a name for the new profile, and then click Next.
  8. Follow the remaining steps of the Microsoft Outlook Setup Wizard to configure each of the services that you selected.
  9. In the When starting Microsoft Outlook, use this profile list, click the new profile that you created, and then click Close.
  10. Start Microsoft Outlook to use the new profile.

MORE INFORMATION

For additional information, click the article numbers below to view the articles in the Microsoft Knowledge Base:

195500 OL2000: (CW) Configuring the Internet E-mail Information Service

196633 OL2000: How to Troubleshoot Invalid Page Faults (IPF) in Outllib

195718 OL2000: (CW) How to Create a New E-mail Profile for Outlook

195507 OL2000: Switching from One Installation Type to Another


Modification Type:MinorLast Reviewed:1/7/2006
Keywords:kberrmsg kbprb KB320856