PRB: Cannot Install BizTalk Accelerator for HIPAA on Cluster (320826)



The information in this article applies to:

  • Microsoft BizTalk Server Accelerator for HIPAA 1.0
  • Microsoft BizTalk Server 2000
  • Microsoft BizTalk Server 2002

This article was previously published under Q320826

SYMPTOMS

When you try to install the HIPAA Accelerator for Biztalk on a Biztalk cluster environment, you may receive the following error message:
Internal Error 2740 :UpdateParserOrder_Install, -1061153517

CAUSE

This problem is caused by a problem that occurs when the UpdateParserOrder_Install custom installer action on a BizTalk Server that is installed in a cluster runs.

RESOLUTION

  1. Remove the BizTalk Messaging Service and IInterchange Application from the BizTalk Messaging Group in the Cluster Administrator.
  2. Perform the following procedure on each node in the cluster:
    1. Open the BizTalk Administrator MMC, and then remove the BizTalk Server from the BizTalk Server group. The BizTalk Server that is listed in the group uses the same name as the network name resource that is specified in the BizTalk Messaging group of the Cluster Administrator.
    2. Add a BizTalk Server with the machine name of the current node to the BizTalk Server group.
    3. Start the BizTalk Messaging Service on the current node.
    4. Install the BizTalk Accelerator for HIPAA and "BizTalk Accelerator for HIPAA 1.0 SP1a":
    5. Stop the BizTalk Messaging service on the current node.
    6. Start the BizTalk Administrator MMC, and then remove the BizTalk Server with the machine name of the current node from the BizTalk Server group.
    7. Add a BizTalk Server to the BizTalk Server group with the same name as the network name resource that you used in the BizTalk Messaging group (as configured in the Cluster Administrator).
  3. In the Cluster Administrator tool:
    1. Add the BizTalk Messaging service resource back to the Cluster by following the steps that are described in the BizTalk Clustering Considerations white paper:
    2. Add the IInterchange Application resource back to the Cluster by following the steps that are described in the BizTalk Clustering Considerations white paper:
    3. Bring both of these resources online.

STATUS

This behavior is by design.

Modification Type:MajorLast Reviewed:6/4/2003
Keywords:kbnofix kbprb kbsetup KB320826