"Network Path not Found" Error Message When You Connect to Non-Client-Side Caching Managed Shares (320819)



The information in this article applies to:

  • Microsoft Windows 2000 Professional
  • Microsoft Windows XP Professional

This article was previously published under Q320819

SYMPTOMS

If one file server contains both shares that are made available offline (Client-Side Caching managed) and shares that are not made available offline (not Client-Side Caching managed), you may not be able to connect to the non-Client-Side Caching-managed shares before you re-synchronize the Client-Side Caching-managed shares. When you cannot connect to the share, you receive a "Network Path not found" error message.

Example

A user maps the following network drives in Windows Explorer:
  • Drive X is \\test-server\csc-share
  • Drive Y is \\test-server\ordinary-share
For drive X, all files are made available offline. For drive Y, files are not made available offline.

If the user now disconnects from the network, the user can still see the files on drive X because they are now cached locally. Drive Y is unavailable. The user receives a Client-Side Caching icon that states that the server "\\test-server" is now offline.

If the reconnects to the network by using RAS, the user still cannot connect to drive Y until an attempt to use the Client-Side Caching icon to reconnect to drive X is made. Any attempts to use drive Y result in the following error message:
Network Path not found

CAUSE

As of April 2002, Client-Side Caching is designed so that the shares of one specific server are either all online or all offline. In the preceding example, because drive X remains offline until the changes have been merged with the Client-Side Caching icon, drive Y also remains off-line until this occurs.

RESOLUTION

To work around this behavior, use the Client-Side Caching icon to reconnect to the server.

STATUS

This behavior is by design.

Modification Type:MajorLast Reviewed:6/4/2003
Keywords:kberrmsg kbnetwork kbprb KB320819