Error Message on a Blue Screen During a Screen Refresh that Uses GDI Halftoning in Windows 2000 (320667)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional

This article was previously published under Q320667

SYMPTOMS

You may receive a BugCheck 1E, {c0000005, a00b328c, 0, 1f5dfd8} error message on a blue screen during a screen refresh that uses GDI Halftoning.

CAUSE

This problem may occur if the rectangle that is being passed to EngStretchBlt is larger than the actual buffer that is allocated for the rectangle.

RESOLUTION

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Windows 2000 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time            Size       File name
   ---------------------------------------------------
   13-May-2002  19:17              42,256  Basesrv.dll
   15-Nov-2001  16:27               5,149  Empty.cat
   13-May-2002  19:17             222,480  Gdi32.dll
   16-May-2002  12:34               1,804  Hotfix.txt
   13-May-2002  19:17             708,880  Kernel32.dll
   19-Apr-2002  17:45               3,584  Spmsg.dll
   19-Apr-2002  17:46              44,032  Spuninst.exe
   12-Jun-2001  10:05               3,856  Svcpack1.dll
   31-May-2002  13:14    <DIR>             Symbols
   31-May-2002  13:14    <DIR>             Uniproc
   31-May-2002  13:14    <DIR>             Update
   25-Jun-2001  19:17              47,808  User.exe
   13-May-2002  19:17             402,192  User32.dll
   13-May-2002  19:17             369,936  Userenv.dll
   13-May-2002  19:15           1,642,224  Win32k.sys
   03-May-2002  11:31             178,960  Winlogon.exe
   13-May-2002  19:17             243,472  Winsrv.dll
				

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

For additional information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the article number below to view the article in the Microsoft Knowledge Base:

265173 The Datacenter Program and Windows 2000 Datacenter Server Product

For additional information about how to install multiple hotfixes with only one reboot, click the article number below to view the article in the Microsoft Knowledge Base:

296861 Use QChain.exe to Install Multiple Hotfixes with One Reboot


Modification Type:MinorLast Reviewed:10/11/2005
Keywords:kbHotfixServer kbQFE kbbug kbdisplay kbenv kbfix kbQFE kbWin2000preSP4Fix KB320667