Error Message: <Systemroot>\System32\Mapisrvr.exe Cannot Access a Necessary File, "Gapi32.dll" (320550)
The information in this article applies to:
- Microsoft Windows XP Home Edition
- Microsoft Windows XP Professional
This article was previously published under Q320550 SYMPTOMS
When you run Norton WinDoctor on a Microsoft Windows XP-based computer, you may receive one of the following error messages:
Message 1
C:\Windows\System32\Mapisrvr.exe" cannot access a necessary file, "Gapi32.dll"
Message 2
C:\Winnt\System32\Mapisrvr.exe" cannot access a necessary file, "Gapi32.dll"
Additionally, if you try to use Norton WinDoctor from Symantec Corporation to repair this issue, WinDoctor reports that it cannot fix it, even though the file exists on the computer's hard disk.
CAUSE
This behavior may occur when you use Norton WinDoctor, and WinDoctor cannot locate the Gapi32.dll file in the
Systemroot\System32 folder.
This is a known issue with Norton WinDoctor. It has been reported to occur with Norton Utilities 2002 v6.0 (of which Norton WinDoctor is a feature), and with Norton SystemWorks 2002 (of which Norton Utilities is a component product).
For more information, visit the following Symantec Corporation Web site:
RESOLUTION
To resolve this behavior, use one of the following methods.
Method 1: Copy the Gapi32.dll File to the Systemroot\System32 Folder
Copy the Gapi32.dll file to the Systemroot\System32 folder on the hard disk. To do this, follow these steps:
- Start Windows Explorer, and then locate the folder that contains the Gapi32.dll file. The Gapi32.dll file is located in one of the following folders:
C:\Program Files\Common Files\System\Mapi\1033
-or-
C:\Program Files\Common Files\System\Mapi\1033\NT
- Right-click the Gapi32.dll file, and then click Copy.
- Click the Systemroot\System32 folder that best applies to your situation:
- <drive letter>:\Windows\System32\Mapisrvr.exe cannot access a necessary file, "Gapi32.dll"
- <drive letter>:\Winnt\System32\Mapisrvr.exe cannot access a necessary file, "Gapi32.dll"
- On the Edit menu, click Paste.
- Quit Windows Explorer.
- Restart the computer.
For more information, visit the following Symantec Corporation Web site:
Method 2: Configure Norton WinDoctor to ignore the error
Configure Norton WinDoctor to ignore the error. Because the error message that is described in the "Symptoms" section of this article is an issue with Norton WinDoctor, and not an issue with Windows files, you may decide to ignore the error message.
For more information about how to configure Norton WinDoctor to ignore the error message, see the product documentation, or visit the following Symantec Corporation Web site:
Modification Type: | Major | Last Reviewed: | 1/25/2006 |
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Keywords: | kberrmsg kbprb KB320550 |
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