Commerce Server 2000 may stop responding for 120 seconds (320480)



The information in this article applies to:

  • Microsoft Commerce Server 2000

This article was previously published under Q320480

SYMPTOMS

Commerce Server 2000 may not respond to requests for up to 120 seconds, but does eventually recover.

CAUSE

When the connection to the computer that is running Microsoft SQL Server is lost, a new connection is not established for up to 120 seconds.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question. The English version of this fix should have the following file attributes or later:
   Date         Time   Version      Size    File name
   --------------------------------------------------
   01-Apr-2002  19:56  4.0.3041.0   61,712  Dsdb3.dll
   03-Apr-2002  12:06                4,300  Hotfix.txt
   21-Mar-2002  13:20  1.0.0.2      82,012  Hotfixsetup.exe
   01-Apr-2002  20:59                  537  Qfehotfix.ini
   01-Apr-2002  20:22              116,736  Qfepatch.msp
   01-Apr-2002  20:24                7,168  Qfeunpatch.msp
  
				

STATUS

Microsoft has confirmed that this is a problem in Microsoft Commerce Server 2000.

This problem was first corrected in Commerce Server 2000 Service Pack 2.

MORE INFORMATION

The retry interval in Dsdb3.dll has been changed from 120 seconds to 30 seconds and the number of retry attempts has been changed from 3 to 30. You cannot configure these parameters.


Modification Type:MinorLast Reviewed:10/11/2005
Keywords:kbHotfixServer kbQFE kbQFE kbbug kbCommServ2000preSP2fix kbCommServ2000SP2fix kbfix KB320480