You cannot run Fixmapi.exe, gain access to mail settings, or synchronize Palm Pilot with Outlook (320444)



The information in this article applies to:

  • Microsoft Office XP Professional
  • Microsoft Office XP Small Business
  • Microsoft Office XP Standard
  • Microsoft Office XP Students and Teachers
  • Microsoft Office XP Developer
  • Microsoft Access 2002
  • Microsoft Excel 2002
  • Microsoft FrontPage 2002
  • Microsoft Outlook 2002
  • Microsoft PowerPoint 2002
  • Microsoft Word 2002

This article was previously published under Q320444

SYMPTOMS

You may experience one or more of the following problems:
  • When you try to reinstall Office or run the Fixmapi.exe utility, you may receive the following error message:
    LoadLibrary: GetLastError = 126
  • When you double-click Mail in Control Panel, you may receive the following error message:
    Out of memory or system resources
  • When you synchronize (hotsync) Palm Pilot with Microsoft Outlook, you may receive one of the following error messages:
    Either there is no default mail client or the current mail client cannot fulfill the messaging request.

    -or-

    Unable to communicate with OLE automation interface

CAUSE

These problems may occur if the Mapistub.dll file is missing from your computer. The file may be missing if your installation of Microsoft Outlook Express is incomplete.

RESOLUTION

To resolve this problem, follow these steps:
  1. Insert the Microsoft Office XP CD in the CD-ROM or DVD-ROM drive.

    If Office Setup starts automatically, close it.
  2. Click Start, click Run, type cmd in the Open box, and then click OK.
  3. At the command prompt, type the following command and then press the ENTER key

    expand CD-ROM_DriveLetter:\office1.cab -F:mapistub.dll BootDriveLetter:\Windows\System32

    where BootDriveLetter is the letter of the drive on which Microsoft Windows is installed (typically, drive C). Note that if you use a Microsoft Windows 2000-based computer, replace \Windows with \Winnt in the command.
  4. If you continue to receive any of the error messages listed in the "Symptoms" section of this article, copy the Mapistub.dll file from the \Windows\System32 folder to the following folder:

    BootDriveLetter:\Program Files\Common Files\System\mapi\1033

NOTE: If the issue described in this article results from a corrupted or missing installation of Outlook Express, you may have to reinstall Outlook Express to restore its full functionality.

To reinstall the latest version of Outlook Express, first download and reinstall the most current release Microsoft Internet Explorer. For more information about how to obtain Internet Explorer from Microsoft, visit the following Microsoft Web site:

http://www.microsoft.com/windows/ie/default.asp For additional information, click the following article numbers to view the articles in the Microsoft Knowledge Base:

254623 OLEXP: How to Reinstall Microsoft Outlook Express 5 in Win2000

256219 OLEXP: How to Manually Uninstall and Reinstall Outlook Express 5

MORE INFORMATION

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:2/21/2006
Keywords:kbtshoot kbprb KB320444