You receive a "VC package not available or not registered" error message (320427)



The information in this article applies to:

  • Microsoft Visual Studio .NET (2002), Professional Edition
  • Microsoft Visual Studio .NET (2002), Enterprise Architect Edition
  • Microsoft Visual Studio .NET (2002), Enterprise Developer Edition
  • Microsoft Visual Studio .NET (2002), Academic Edition
  • Microsoft Visual Studio .NET (2003), Professional Edition
  • Microsoft Visual Studio .NET (2003), Enterprise Architect Edition
  • Microsoft Visual Studio .NET (2003), Enterprise Developer Edition
  • Microsoft Visual Studio .NET (2003), Academic Edition
  • Microsoft Visual Studio 2005 Professional Edition
  • Microsoft Visual Studio 2005 Standard Edition
  • Microsoft Visual C++ .NET (2002)
  • Microsoft Visual C++ .NET (2003)
  • Microsoft Visual C++ 2005 Express Edition
  • Microsoft Visual Basic .NET (2002)
  • Microsoft Visual Basic .NET (2003)
  • Microsoft Visual Basic 2005
  • Microsoft Visual C# .NET (2002)
  • Microsoft Visual C# .NET (2003)
  • Microsoft Visual C# 2005, Express Edition
  • Microsoft Visual J# .NET (2002)
  • Microsoft Visual J# .NET (2003)
  • Microsoft Visual J# 2005 Express Edition

This article was previously published under Q320427

SYMPTOMS

When you create a WinForms application, you may receive the following error message:
"VC Package not available or not registered"
This behavior can occur even after what appears to be a successful installation.

CAUSE

This behavior seems to occur because the Windows Installer does not register TLBs and DLLs if the installer finds that these items already exist. In most cases, a previous version of Visual Studio .NET or Visual Studio 2005 causes this behavior, even if the previous installation was under a different operating system.

RESOLUTION

To resolve the problem, run the Visual Studio .NET or Visual Studio 2005 repair. A repair is more effective for fixing this issue because the repair process forces registration of items that are not re-registered during an install.

To run the repair, follow these steps:
  1. On the Start menu, point to Settings, click Control Panel, and then click Add/Remove Programs.
  2. On the list of installed programs, click Visual Studio .NET or Visual Studio 2005, and then click Change.
  3. Click the second item in the 1 2 3 Visual Studio Setup dialog box.
  4. Insert the product CD. If an installation wizard starts, cancel the wizard, and then proceed with the repair as outlined in the following step. If the product CD is not inserted before the next step, the CD may not be recognized.
  5. Click Repair/Re-install, and then follow the onscreen instructions.

MORE INFORMATION

Steps to reproduce the behavior

To reproduce the problem, it is best to have two operating systems installed on separate partitions. Two installations of Windows XP Professional will work.
  1. Install Visual Studio .NET under one operating system.
  2. Install Visual Studio .NET under the other operating system; change the default location to match the installation location of the first installation.
  3. Both installs report as successful.
  4. Start the copy of Visual Studio .NET that you installed in step 2.
This type of installation is never recommended. Even if the installation selections are exactly the same, and you can save disk space by performing this type of installation, the potential for problems is high. If one installation changes files and registry entries, these changes are not recorded by the other installation, which creates a substantial risk for unexpected results.

Modification Type:MinorLast Reviewed:10/3/2006
Keywords:kbvs2005applies kbvs2005swept kbprb kbsetup KB320427 kbAudDeveloper