SMS: Client Components Change to "Install Pending" After You Restart the SMS Client Service (320235)



The information in this article applies to:

  • Microsoft Systems Management Server 2.0

This article was previously published under Q320235

SYMPTOMS

After you install the SMS 2.0 client components on a Microsoft Windows 2000-based member server or workstation, some of the client components may change to "Install Pending" after the 23 hour CCIM cycle, or after you restart the SMS Client service. The following components may be affected:
  • Software Distribution Agent
  • Software Inventory Agent
The Clisvc.log file may contain the following error entry:
***ERROR: Unable to launch
"C:\WINNT\MS\SMS\clicomp\SWDist32\bin\ODPUSR32.exe " - Error : 1314
*** WNet User Groups Offer Data Provider - Error launching (#0x3EB)
!!!WARNING: Problem starting App (1003). Doing App Verify.

CAUSE

This behavior may occur if a domain security policy restricts a required privilege of the local SMSCliSvcAcct& account on the SMS client computer. For example, "Replace process level token" may cause this behavior.

WORKAROUND

To work around this behavior, add the required security rights to the domain security policy for the SMSCliSvcAcct& account.

MORE INFORMATION

Error 1314 is "A required privilege is not held by the client."

The local security policy requirements for the SMSCliSvcAcct& account are:
  • Act as part of the operating system.
  • Increase the quotas.
  • Logon as a service.
  • Replace a process-level token.
  • Turn off the computer.
Note that the SMSCliSvcAcct& account should also be a part of the local administrators group on the SMS client computer.

For additional information about a related topic, click the article number below to view the article in the Microsoft Knowledge Base:

295771 Restricted Group Policy Prevents SMS Client Installation


Modification Type:MinorLast Reviewed:7/8/2005
Keywords:kbConfig kbprb kbSecurity kbui KB320235