IntelliMouse: Mouse does not work as expected after successful installation (320194)



The information in this article applies to:

  • Microsoft IntelliMouse Explorer for Bluetooth 2.0
  • Microsoft Optical Desktop Elite for Bluetooth 2.0
  • Microsoft Wireless IntelliMouse Explorer 2.0
  • Microsoft Wireless Intellimouse Explorer for Bluetooth
  • Microsoft Wireless Intellimouse Explorer USB
  • Microsoft Wireless Laser Mouse 8000

This article was previously published under Q320194

SYMPTOMS

When you try use the Microsoft Wireless IntelliMouse Explorer pointing device, the device does not work correctly after what appears to be a successful installation. Device Manager confirms that the device is installed successfully.

CAUSE

This issue may occur if the Hidserv.exe file was not installed during the hardware installation process.

This issue may also occur if incorrect files from an earlier installation remain installed on your computer.

RESOLUTION

Note Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.
To resolve this issue, use one or both of the following methods, as necessary.

Method 1: Remove and reinstall the mouse and drivers

Note Because your mouse may not be working, these steps use Microsoft Windows keyboard shortcuts.

Remove the mouse through Device Manager

  1. Unplug the mouse from your computer.
  2. Press CTRL+ESC, use the arrow keys to select Control Panel, and then press ENTER.
  3. Use the arrow keys to select System, and then press ENTER.
  4. Use the arrow keys to select the Hardware tab, press TAB to select Device Manager, and then press ENTER.
  5. Press TAB, use the arrow keys to select Human Interface Devices (may also be labeled Mouse or Mice and other pointing devices), and then press RIGHT ARROW to expand the item.
  6. Use the arrow keys to select the mouse in question (it may be labeled HID Consumer control device or Unknown), and then press ALT+F10.
  7. On the Shortcut menu, press TAB to select Uninstall, and then press ENTER.
  8. Follow the instructions to completely remove (uninstall) the mouse.

Reinstall the mouse and drivers

  1. Reconnect your mouse to the USB port on the computer.

    At this point, the mouse may be detected, and then installation starts automatically. If so, follow the instructions to complete the installation process. If not, proceed to the next step.
  2. Press CTRL+ESC.
  3. Use the arrow keys to select Control Panel, and then press ENTER.
  4. Use the arrow keys to select System, and then press ENTER.
  5. Use the arrow keys to select the Hardware tab, press TAB to select Device Manager, and then press ENTER.
  6. Press ALT+A, and then select Scan for hardware changes to refresh the Device Manager.
  7. Mouse installation should start automatically. Follow the instructions to complete the installation process.
Note If this does not resolve the issue, proceed to Method 2.

Method 2: Extract files from the Windows CD

Locate the files on your hard disk drive

  1. Press CTRL+ESC.
  2. Use the arrow keys to select Search, and then press ENTER.
  3. Use the TAB and ARROW keys to search for the following files on your system drive, and then note the location of each -- for example, C:\Windows\system32\drivers.

    Note One or more of the following files may not be present on your computer.
    • Usbhub.sys
    • Usbd.sys
    • Uhcd.sys (if you are using an Intel USB controller or Via-Tech)
    • Openhci.sys (if you are using a controller other than the Intel USB controller, such as SiS, or ALi.)
    • Hidclass.sys
    • Hidparse.sys
    • Hidusb.sys
    • Hidvkd.sys
    • Hiddev.inf
    • Mmdevldr.vxd
    • Hid.dll

Locate the files on your Windows CD and extract them

  1. Press CTRL+ESC.
  2. Use the arrow keys to select Search, and then press ENTER.
  3. Use the TAB and ARROW keys to search your Windows CD-ROM for the each file that you located in the "Locate the Files on Your Hard Disk" section of this article.
  4. When the search process is complete, use the TAB key to browse to the file, use the RIGHT ARROW key to select it, and then press SHIFT+F10 to open the shortcut menu.
  5. Use the arrow keys to select Extract, and then press ENTER.
  6. Use the ARROW keys to select the folder that you noted as the location for this file in step 3 of the "Locate the Files on Your Hard Disk" section of this article, and then select this folder as the destination.
  7. Restart the computer.

MORE INFORMATION

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.
For more information about how to extract files on a non-Microsoft Windows XP-based computer, click the following article number to view the article in the Microsoft Knowledge Base:

129605 How to extract original compressed Windows files


Modification Type:MajorLast Reviewed:9/26/2006
Keywords:kbprb KB320194