Windows Media Player 7 individualization process breaks the DRM client on Windows Millennium Edition (320150)



The information in this article applies to:

  • Microsoft Windows Media Player 7, when used with:
    • the operating system: Microsoft Windows Millennium Edition
  • Microsoft Windows Media Player 7.1, when used with:
    • the operating system: Microsoft Windows Millennium Edition

This article was previously published under Q320150

SYMPTOMS

When you use Windows Media Player 7.0 (version 7.00.00.1440) on Windows Millennium Edition (Windows Me), the player does not obtain the license after individualization to version 2.2, and you receive the following error message:
A problem has occurred in the Digital Rights Management component. Contact product support for this application.
Note The error code is C00D2751.

CAUSE

During individualization, the application contacts the Microsoft Individualization Service, which installs a security upgrade on your computer. Individualization can occur when you play a packaged file.

The application sends the license request to the Windows Media License Service, which inspects the certificate of the application that is requesting the license. If the Digital Right Management (DRM) component of the application has not been individualized, Windows Media License Service refuses to issue the license. The policy of Windows Media License Service is to issue licenses only to individualized players.

The application then notifies you that the application must be upgraded. If you agree, a security upgrade is provided to individualize the DRM component of the application.

On Windows Me, if Windows Media Player 7.00.00.1440 never obtains a version 7 license before being individualized, the individualization process breaks the DRM client.

RESOLUTION

To resolve this problem, obtain Windows Media Player 9 Series. You may obtain the latest version of the Windows Media Player for Windows Me from the following Microsoft Web site: .

MORE INFORMATION

Microsoft Windows Media Player 7 is no longer supported. Additionally, you cannot resolve this problem by upgrading to Windows Media Player 7.1 (version 7.01.00.3055).

For more information about the Microsoft Support Lifecycle policy, visit the following Microsoft Web site:

Modification Type:MinorLast Reviewed:9/8/2005
Keywords:kbDSWMM2003Swept kbprb KB320150