XADM: The Information Store and MTA Services May Not Start After You Apply SP2 (320039)



The information in this article applies to:

  • Microsoft Exchange 2000 Server

This article was previously published under Q320039

SYMPTOMS

After you apply Service Pack 2 (SP2) to an Exchange 2000 computer, the Information Store service and the message transfer agent (MTA) service may not start and the following event ID messages may be logged in the application event log:
Event Source: MSExchangeIS
Event Category: General
Event ID: 1121
Description:
Error 0x80004005 connecting to the Microsoft Active Directory.

-and-

Event Source: MSExchangeMTA
Event Category: Configuration
Event ID: 125
Description:
A fatal error occurred reading a value from the directory. No MTA name was found. Contact Microsoft Technical Support. [MTA MAIN BASE 1 12] (16)

CAUSE

This problem may occur if the global catalog server is located in a different domain than the Exchange 2000 computer. In this situation, the Exchange 2000 computer cannot contact the global catalog server.

NOTE: This problem may occur after you apply SP2 even if a global catalog server is present in the same Active Directory site or forest as the Exchange 2000 computer.

RESOLUTION

To resolve this problem, set the System Access Control List (SACL) permission for the domain in which the global catalog server is located, and then configure a Recipient Update Service for the domain.

How to Set the SACL Permission

To set the SACL permission, run the Exchange Server Setup program with the /domainprep switch in the domain in which the global catalog server is located. You must have the following rights to complete this procedure:
  • Domain Administrator rights in the domain in which the global catalog server is located
  • Local Administrator rights
To set the SACL permission:
  1. Insert the Exchange 2000 compact disc (CD).
  2. Click Start, click Run, type the following command (where drive_letter is the drive in which you inserted the CD), and then click OK:

    drive_letter:\setup\i386\setup.exe /DomainPrep

    NOTE: Make sure that you type the correct path to the Setup.exe file on the CD in the command.

How to Configure a Recipient Update Service

  1. Start Exchange System Manager.
  2. Expand the Recipients object in the left pane
  3. Right-click the Recipient Update Services container, point to New, and then click Recipient Update Service.
  4. Click Browse next to Domain, click the domain in which the global catalog server is located, and then click OK.
  5. Click Next.
  6. Click Browse, click the name of the Exchange 2000 computer on which you want to run this instance of the Recipient Update Service, and then click OK.
  7. Click Next.

    The following message is displayed in the last page of the wizard:

    Recipient Update Service Name: Recipient Update Service (TESTDOMAIN)
    Windows 2000 Domain: testdomain.com
    Domain Controller: testserver1.testdomain.com
    Exchange Server: TESTSERVER1

    The Exchange 2000 computer is granted the rights to modify Exchange 2000 attributes on recipients in the domain.
  8. Click Finish.

WORKAROUND

To work around this problem, either install a global catalog server or promote a domain controller to a global catalog server in the domain in which the Exchange 2000 computer is located.

STATUS

Microsoft has confirmed that this is a problem in Exchange 2000.

MORE INFORMATION

For more information about this problem, see the "Directory Access Requirements" section of the Release Notes for Exchange 2000 SP2. The following Microsoft Knowledge Base article contains links to the different language versions of the Exchange 2000 SP2 Release Notes:

311719 XGEN: Release Notes for Exchange 2000 Server Service Packs


Modification Type:MinorLast Reviewed:4/25/2005
Keywords:kbbug KB320039