Error Message: "A File That Is Required to Run Search Companion Cannot Be Found" (319949)



The information in this article applies to:

  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional

This article was previously published under Q319949

SYMPTOMS

After you connect to a Web site, you may receive the following error message:
A file that is required to run search companion cannot be found. You may need to run setup.
After you receive this error message, you cannot use Search Companion to search for files or folders, or to search the Internet. The options to search for files or folders, or to search the Internet, are unavailable.

CAUSE

This behavior can occur if a file required to run Search Companion is missing or damaged. Note that this problem affects only the English-language version of Windows XP.

NOTE: Search Companion files may be damaged if you have Search Companion open when you connect to certain Internet Service Providers.

RESOLUTION

To resolve this problem, use one of the following methods.

Method 1: Install Windows XP SP1

To resolve this problem, obtain the latest service pack for Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to Obtain the Latest Windows XP Service Pack

Method 2: Download and Install the Hotfix

The following file is available for download from the Microsoft Download Center:
Release Date: June 1, 2002

For additional information about how to download Microsoft Support files, click the following article number to view the article in the Microsoft Knowledge Base:

119591 How to Obtain Microsoft Support Files from Online Services

Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help to prevent any unauthorized changes to the file. The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version     Size     File name
   ---------------------------------------------------
   25-Mar-2002  22:54  1.0.0.2714  798,782  Srchui.dll       
				

Method 3: Reinstall the Search Companion Files

To resolve this problem without obtaining the hotfix or installing Windows XP SP1, follow these steps:
  1. Log on to the computer by using an account with administrator permissions.
  2. Click Start, click Run, type %systemroot%\inf, and then click OK.
  3. Locate the Srchasst.inf file.
  4. Right-click the Srchasst.inf file, and then click Install. This reinstalls the files that Search Companion uses.
NOTE: You may need your Windows XP CD-ROM to finish installing Search Companion. This issue may occur again if you have Search Companion open when you connect to your ISP.

The problem may continue to occur after you disconnect from the Internet because the files that have been corrupted are cached. You can view the appropriate files (open them with Notepad, not Microsoft Internet Explorer) to determine the source of the corruption. The files that are involved are:
  • Balloon.xsl
  • Bar.xsl
  • Lclsrch.xml

WORKAROUND

To prevent this problem from occurring, make sure the Search Companion is closed before you connect to your ISP.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Windows XP Service Pack 1.

Modification Type:MinorLast Reviewed:9/27/2005
Keywords:kbHotfixServer kbQFE kberrmsg kbbug kbfix kbQFE KB319949