Cannot Print to a File on a Terminal Services Server (319894)
The information in this article applies to:
- Microsoft Windows 2000 Server SP1
- Microsoft Windows 2000 Server SP2
- Microsoft Windows 2000 Advanced Server SP1
- Microsoft Windows 2000 Advanced Server SP2
- Microsoft Windows 2000 Professional SP1
- Microsoft Windows 2000 Professional SP2
This article was previously published under Q319894 SYMPTOMS
If you configure a printer port as "FILE:" on a Terminal Services server, you are prompted to type a file name for the spool file when you print a document. If you specify a file on a drive letter that is mapped to a network share, the print job does not succeed if you are logged on to a Terminal Services server by using the Terminal Services Client software. The problem does not occur if you are logged on to the Terminal Services server at the console.
CAUSE
The print spooler runs in the System context and has no access to the drive mappings in the you user session.
RESOLUTIONTo resolve this problem, obtain the latest service pack for Windows 2000. For additional information, click the following article number to view the article in the
Microsoft Knowledge Base:
260910 How to Obtain the Latest Windows 2000 Service Pack
The English version of this fix should have the following file attributes or later:
Date Time Version Size File name
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21-Mar-2002 23:35 5.0.2195.5225 114,448 Winspool.drv
21-Mar-2002 23:35 5.0.2195.4967 54,032 Wlnotify.dll
WORKAROUND
To work around this problem, use an output file name in Universal Naming Convention UNC notation (such as \\Server\Share\Output.bin).
STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Windows 2000 Service Pack 3.
Modification Type: | Minor | Last Reviewed: | 9/27/2005 |
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Keywords: | kbHotfixServer kbQFE kbbug kbfix kbTermServ kbWin2000PreSP3Fix kbWin2000sp3fix KB319894 |
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