You receive an HTTP_500 error message when you synchronize a mobile device by using Microsoft Server ActiveSync (319681)



The information in this article applies to:

  • Microsoft Mobile Information Server 2002

This article was previously published under Q319681

SYMPTOMS

Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

When you synchronize a mobile device by using Microsoft Server ActiveSync, you receive the following error message:
Error code: HTTP_500 Synchronization failed due to an error on the server. Try again.

CAUSE

This issue occurs because Microsoft Server ActiveSync typically locates the mailbox by using the left side of the primary Simple Mail Transfer Protocol (SMTP) address.

RESOLUTION

There are two possible resolutions for this issue:
  • Change the left side of the primary SMTP address to match the mailbox.
  • Install a new feature that Microsoft has created that lets you configure a new registry key. The new registry key forces Microsoft Server ActiveSync to look through the secondary SMTP addresses.

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

After you install the hotfix

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

To enable the feature that is contained in the hotfix, you must add a registry key that forces Microsoft Server ActiveSync to look through the secondary SMTP addresses. To do this, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate the following registry key:

    HKEY_Local_Machine\System\CurrentControlSet\Services\MasSync\Parameters

  3. Right-click Parameters, click New, and then click String Value.

    New value #1 is selected.
  4. To rename the value, type SMTPProxy, and then press ENTER.
  5. Right-click SMTPProxy, and then click Modify.
  6. In the String Data box, type the SMTP domain that you want, and then click OK.

    For example, type cohovineyard.com.
  7. Quit Registry Editor.
  8. Restart the IIS Admin service. To do this, follow these steps:
    1. Click Start, click Run, type services.msc, and then click OK.
    2. In the list of services, right-click IIS Admin service, and then click Restart.
After you apply the new registry setting, Microsoft Server ActiveSync looks for the secondary SMTP address.

For example, if a user at Coho Vineyard and Winery has a primary SMTP address of admin@cohovineyard.com and a secondary SMTP address of terryadams@cohovineyardandwinery.com, Microsoft Server ActiveSync correctly looks for the mailbox that uses the terryadams@cohovineyardandwinery.com SMTP address.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

REFERENCES

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

886346 You receive an HTTP_500 error message when you synchronize your mobile device with Microsoft Exchange Server 2003


Modification Type:MajorLast Reviewed:11/30/2005
Keywords:kbtshoot kbbug kbfix KB319681