"Windows Installer Service could not be accessed" error message when installing application (319624)



The information in this article applies to:

  • Microsoft Windows Installer 1.0, when used with:
    • the operating system: Microsoft Windows NT 4.0 SP6
    • the operating system: Microsoft Windows 2000 SP1
    • the operating system: Microsoft Windows 2000 SP2
    • the operating system: Microsoft Windows 2000 SP3
  • Microsoft Windows Installer 1.1, when used with:
    • the operating system: Microsoft Windows NT 4.0 SP6
    • the operating system: Microsoft Windows 2000 SP1
    • the operating system: Microsoft Windows 2000 SP2
    • the operating system: Microsoft Windows 2000 SP3
  • Microsoft Windows Installer 1.2, when used with:
    • the operating system: Microsoft Windows NT 4.0 SP6
    • the operating system: Microsoft Windows 2000 SP1
    • the operating system: Microsoft Windows 2000 SP2
    • the operating system: Microsoft Windows 2000 SP3
  • Microsoft Windows Installer 2.0, when used with:
    • the operating system: Microsoft Windows NT 4.0 SP6
    • the operating system: Microsoft Windows 2000 SP1
    • the operating system: Microsoft Windows 2000 SP2
    • the operating system: Microsoft Windows 2000 SP3

This article was previously published under Q319624

SYMPTOMS

After you upgrade to Windows Installer version 2.0, the Windows Installer Service may not start, and you may receive the following error message:
The Windows Installer Service could not be accessed. This can occur if you are running Windows in safe mode, or the Windows Installer is not correctly installed. Contact your support personnel for assistance.
Note This behavior does not occur in the following products:
  • Microsoft Windows XP
  • Microsoft Windows Millennium Edition
  • Microsoft Windows 98

CAUSE

This behavior can occur when either of the following conditions exist:
  • In the DCOM permissions, the default authentication level is set to None, and the default Impersonation level is set to Anonymous.
  • The system account does not have Full permissions on a folder or registry key that the Windows Installer is trying to access. This is NTFS-specific.

RESOLUTION

Depending on the issue, use one or all of the following methods:
  • Method 1: Unregister and re-register Windows Installer.
  • Method 2: Verify the DCOM permissions.
  • Method 3: Give Full Control permission to the SYSTEM account.
  • Method 4: Verify the registry permissions.
  • Method 5: Fix the broken security key for the MsiServer service.

Before you begin: Verify that the service pack is installed

If you are using Windows 2000, make sure that SP 2 is installed.
If you are using Windows NT 4.0, make sure that SP 6 is installed.

If you do not install the appropriate service packs, the steps in the "More Information" section of this article may not work as expected.

MORE INFORMATION

Method 1: Unregister and re-register the Windows Installer

  1. Click Start, click Run, type MSIEXEC /UNREGISTER, and then click OK. Even if you do this correctly, it may look like nothing occurs.
  2. Click Start, click Run, type MSIEXEC /REGSERVER, and then click OK. Even if you do this correctly, it may look like nothing occurs, or you may briefly see an hourglass. After you run this command, the operation is complete.
  3. Try your Windows Installer-based application again.

Method 2: Verify the DCOM permissions

This method involves changing the DCOM default impersonation level to Identify, removing the Msisip.dll file, and then reinstalling SP 3 for Windows 2000.

To do this, follow these steps:
  1. Click Start, click Run, type dcomcnfg, and then click OK.
  2. On the Default Properties tab:
    1. In the Default Authentication Level list, click Connect.
    2. In the Default Impersonation Level list, click Identify, and then click OK.
  3. Click Start, click Run, type explorer /select, %windir%\system32\msisip.dll, and then click OK.
  4. Rename the Msisip.dll file as Msisip.old.
  5. Reinstall Windows 2000 Service Pack 3.

Method 3: Give Full Control permission to the SYSTEM account

  1. Start Windows Explorer, right-click the computer's root hard drive, and then click Properties.
  2. Click the Security tab, and then click Add.
  3. In the Select Users, Computers, or Groups dialog box, click the SYSTEM account, click Add, and then click OK.
  4. Under Allow, click to select the Full Control check box, and then click OK.
  5. Click the TEMP folder and then verify that the SYSTEM account has full control.

Method 4: Verify the registry permissions

  1. Click Start, click Run, then type Regedt32.
  2. For each of the registry hives, follow these steps:
    1. Select the hive.
    2. For Windows XP, on the Edit menu, click Permissions.

      For Windows 2000 and Windows NT 4, on the Security menu, click Permissions.
  3. Verify that the SYSTEM account has been added and that it has Full control. If it does not, add the SYSTEM account with Full control.

Method 5: Fix the broken security key for the MsiServer service

  1. Start the computer by using Windows 2000.
  2. Click Start, click Run, type regedit.exe, and then rename the following key to Old_Security:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSIServer\Security

  3. Restart the computer (you must do this).
  4. Run Instmsiw.exe for installer 2.0 again; this corrects the broken security key for the MSI service.

Modification Type:MinorLast Reviewed:8/30/2005
Keywords:kbPubTypeKC kbprb KB319624 kbAudDeveloper