SYMPTOMS
When you use Outlook 2002 on Microsoft Windows 2000
Terminal Services, you may receive the following error message:
Outlook failed to start correctly last time. Starting
Outlook in safe mode will help you correct or isolate a startup problem in
order to successfully start the program. Some functionality may be disabled in
this mode.
Do you want to start Outlook in safe mode?
If
you click
Yes or
No, Outlook 2002 starts. The next time that you start Outlook 2002,
you do not receive the error message, but you do receive the error message the
next time that you start Outlook 2002 after that. This loop of receiving the
error message every other time that you start Outlook 2002 continues
indefinitely.
CAUSE
This problem occurs because subkeys are written under the
Resiliency key and the
Resiliency key is not deleted if you have an unsuccessful startup test in
Outlook 2002. If the
Resiliency key remains, you receive the error message that is referenced in
the "Symptoms" section the next time that you start Outlook 2002.
The following is an example of how subkeys are written under the
Resiliency key
HKEY_LOCAL_MACHINE\Windows NT\Current Version\Terminal
Server\Install\Software\Microsoft\Office\10.0\Outlook\Resiliency
with the
TermSrvCopyKeyOnce key having a value of 0x1 in the registry on the Windows 2000
Terminal Services in one of the subkeys under the
Resiliency key.
When Outlook 2002 starts, the following registry
key is created:
HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Outlook\Resiliency
NOTE: The
Resiliency key for Microsoft Outlook is new for Outlook 2002.
If
you do not experience any problems, the
Resiliency key is deleted. If one of the many tests that Outlook 2002 makes
during startup fail, subkeys are written under the
Resiliency key and the
Resiliency key is not deleted.
If a subkey is deleted by a program
from the
HKEY_CURRENT_USER (HKCU) registry key, specifically a subkey from the following registry
key
HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Outlook\Resiliency
while the server is in Terminal Server Install mode,
the data is copied to the
HKEY_LOCAL_MACHINE (HKLM) registry key as in the following example:
HKLM\Software\Microsoft\Windows NT\Current Version\Terminal Server\Install\Software\\Microsoft\Office\10.0\Outlook\Resiliency
When the program tries to access the
HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Outlook\Resiliency registry key again while the server is in Terminal Server
Application mode and finds it missing, the program looks in the HLKM location,
specifically in
HKLM\Software\Microsoft\Windows NT\Current Version\Terminal Server\Install\Software\\Microsoft\Office\10.0\Outlook\Resiliency,for the key. If the
Resiliency key is there and has the
TermSrvCopyKeyOnce registry key under one of the subkeys of the
Resiliency key, the
Resiliency key is written back to HKCU.
In this case, the
Resiliency key was written with subkeys while in Terminal Server Install
mode. After the terminal server goes back to Terminal Server Application mode,
every user is affected because Outlook 2002 always looks for the
Resiliency key, and therefore causes the loop.