You receive an HTTP 408 or 409 error message when you try to connect to a Web server through ISA Server 2000 (319378)



The information in this article applies to:

  • Microsoft Internet Security and Acceleration Server 2000

This article was previously published under Q319378

SYMPTOMS

When you try to access a Web site on a third-party Web server, you may experience one of the following symptoms after a 30-second delay:
  • You receive a blank page.
  • You receive an HTTP Error 408 error message.
  • You receive an HTTP Error 409 error message.
If you refresh the page in your Web browser, the page loads correctly.

CAUSE

This problem may occur if you use Microsoft Internet Security and Acceleration (ISA) Server 2000 as a Web proxy. When an HTTP POST is sent through ISA Server, and ISA Server is acting as a Web proxy, ISA Server splits the POST into two TCP segments. The first segment contains the headers. The second segment contains the data for the POST. The Web server may respond to the first segment before the second segment has been received and processed.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for ISA Server 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

313139 How to obtain the latest Internet Security and Acceleration Server 2000 service pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next ISA Server 2000 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must have ISA Server 2000 Service Pack 1 (SP1) to apply this hotfix.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version       Size     File name
   -------------------------------------------------------
   25-Oct-2002  00:21  3.0.1200.179  176,912  Mspadmin.exe
   25-Oct-2002  00:21  3.0.1200.179   99,600  Msphlpr.dll
   25-Oct-2002  00:20  3.0.1200.179  388,368  W3proxy.exe
   25-Oct-2002  00:21  3.0.1200.179  297,232  Wspsrv.exe
After you apply this hotfix, ISA Server sends the HTTP POST in a single packet if it is possible.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:10/10/2005
Keywords:kbHotfixServer kbQFE kbISAServ2000preSP2fix kbWebServer kbClient kbPerformance kbinterop kbQFE kbbug kbfix KB319378 kbAudITPRO