FIX: ISA Server Blocks Incoming Traffic Although a Valid Server Publishing Rule Exists (319377)



The information in this article applies to:

  • Microsoft Internet Security and Acceleration Server 2000
  • Microsoft Internet Security and Acceleration Server 2000 SP1

This article was previously published under Q319377

SYMPTOMS

ISA Server may temporarily block incoming traffic that is destined for a protocol that has a valid Server Publishing rule defined. This blockage typically does not occur for more than a few minutes.

CAUSE

This problem occurs because some Winsock error messages are not handled correctly. When a connection enters a specified state, all traffic that is destined for the Server Publishing rule is blocked by ISA Server for a short time.

RESOLUTION

You must install ISA Server Service Pack 1 (SP1) before you install this hotfix. For additional information about how to obtain the latest ISA Server service pack, click the article number below to view the article in the Microsoft Knowledge Base:

313139 How to Obtain the Latest Internet Security and Acceleration Server 2000 Service Pack

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Internet Security and Acceleration Server 2000 service pack that contains this fix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

To install the fix, run the self-extracting file. You do not have to restart the ISA Server computer. If the computer is part of an ISA Server array, you do not have to shut down the whole array. You can still install this fix on a one-by-one basis.

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date          Time    Version        Size      File name 
--------------------------------------------------------
24-Oct-2002   20:21   3.0.1200.179   176,912   Mspadmin.exe 
24-Oct-2002   20:20   3.0.1200.179   388,368   W3proxy.exe 
24-Oct-2002   20:21   3.0.1200.179   297,232   Wspsrv.exe 
24-Oct-2002   20:21   3.0.1200.179    99,600   Msphlpr.dll 
				
This fix also applies to the French, German, Spanish, and Japanese versions of ISA Server.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:10/11/2005
Keywords:kbHotfixServer kbQFE kbbug kbfix kbISAServ2000preSP2fix kbQFE KB319377