An Agent Does Not Send Performance Information and Has a Delayed Status (319354)



The information in this article applies to:

  • Microsoft Operations Manager 2000

This article was previously published under Q319354

SYMPTOMS

If the OnePoint agent belongs to more than one configuration group, delivery of the performance counters that are monitored by the multi-homed agent may be delayed for up to 24 hours. The agent also may not send heartbeats at regular intervals. This causes the agent's status to appear as delayed in the Microsoft Operations Manager (MOM) 2000 console. You can see this issue when you push new rules to the MOM agent.

CAUSE

This problem may be caused by corrupted performance counters on the MOM agent.

RESOLUTION

To resolve this problem, obtain the latest service pack for Microsoft Operations Manager 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

814529 How to Obtain the Latest Microsoft Operations Manager 2000 Service Pack

The English version of this hotfix has the following file attributes or later:
   Date         Time   Version    Size       File name
   --------------------------------------------------------------------
   03-Apr-2002  14:09  4.0.12.66  2,044,072  Mcscmn04.dll
   03-Apr-2002  14:09  4.0.12.66    338,440  Eemperformanceprovider.dll
				

WORKAROUND

To work around this problem, turn off all of the corrupted performance counters.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Microsoft Operations Manager 2000 Service Pack 1.

MORE INFORMATION

You must install this hotfix on every computer that meets these criteria:
  • The computer hosts a MOM Consolidator (CAM).
  • The computer hosts a manually installed MOM agent.
To apply this hotfix, you must first copy the Q319354.exe file either to a local folder or to an accessible network shared folder, and then run Q319354.exe locally on each computer that meets the criteria. You can run Q319354.exe from Windows Explorer or from a command prompt.

NOTE: If you run Q319354.exe while the MOM Administrator console is running, you must restart the CAM server. It is a good idea to quit the MOM Administrator console before you install this hotfix.

When you install this hotfix on a CAM server, the installation program starts an agent update to all currently managed servers. This process involves the following steps:
  • At the next scheduled Managed Computer scan, the list of agent computers that must be updated appears in the Pending Installation folder in the Configuration snap-in. If you must, you can start the Managed Computer scan immediately by using the following steps:
    1. In the MOM Administrator console, click Configuration, and then click Agent Managers.
    2. In the right pane, right-click Agent Manager.
    3. Click Scan Managed Computers Now.
  • On the CAM computer, you must approve the deployment of the updated agents by locating the agents under the Configuration\Pending Installation node in the MOM tree. After you do this, right-click an agent computer, and then click Approve. The deployment of the updated agent occurs for each managed node only after it has been approved in the Pending Installation folder. To approve all pending operations, right-click Pending Installation, and then click Approve All Pending Actions. If you want the installation to occur as soon as possible, right-click Configuration\Pending Installation, and then click Process All Approved Actions.

Modification Type:MinorLast Reviewed:9/27/2005
Keywords:kbHotfixServer kbQFE kbOpMan2000SP1Fix kbbug kbenv kbfix KB319354