BUG: No Text or Access Violation Error When Reading a Help File (319247)



The information in this article applies to:

  • Microsoft HTML Help 1.3
  • Microsoft HTML Help 1.31
  • Microsoft HTML Help 1.32

This article was previously published under Q319247

SYMPTOMS

When you view an HTML Help file (.chm file name extension), you may receive one of the following:
  • No text in the body of the help file
  • An access violation error message
  • The following error message:
    "Page Cannot Be Displayed"

CAUSE

One or more of the problems in the previous list can occur if the CHM file name or the path to the file contains a number sign (#). If the CHM file name contains the # symbol, then the topics in the table of contents do not appear. If the path contains the # symbol, then you may receive an access violation error message.

RESOLUTION

To work around this issue, remove the # symbol from the file name or from the path to the file.

STATUS

Microsoft has confirmed that this is a bug in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

To check which version of HTML Help you are using, locate the file Hhctrl.ocx on your computer. Right-click Hhctrl.ocx, click Properties, and then verify the version correspondence below:

HHCTRL.OCXHTML HelpTypically on OS
4.74.87021.3Windows 2000
4.74.87931.31Windows 2000(SP1)
4.74.88751.32Windows ME
4.74.92731.33Windows XP

Steps to Reproduce Behavior

To reproduce the problem, follow these steps:
  1. Locate any CHM file on your computer that contains a table of contents. Rename the file so that the file name contains the # symbol.
  2. Double-click the CHM file. Note that the table of contents appears but the topics do not appear in the rightmost pane of the Help window.
  3. Change back the file name of the CHM file to the original name.
  4. Rename the folder that contains the CHM file so that the folder name contains the # symbol.
  5. Double-click the CHM file. You receive an access violation error message.

    NOTE: If you attempt to reproduce the behavior on a computer running Windows XP, then an error report is generated.

Modification Type:MajorLast Reviewed:4/5/2002
Keywords:kbbug KB319247