XADM: You Cannot Perform a Check Names Query Against a Front-End Exchange Computer (319175)



The information in this article applies to:

  • Microsoft Exchange 2000 Server

This article was previously published under Q319175

SYMPTOMS

After you install Exchange 2000 Service Pack 2 (SP2) or later, new Messaging Application Programming Interface (MAPI) profiles may not be able to point to a front-end Exchange computer and perform a check names query.

You may receive a Microsoft Outlook error message that is similar to:
Outlook could not log on. Check to make sure you are connected to the network and are using the proper server mailbox name. Network problems are preventing connection to the Microsoft Exchange Server computer. Contact your system administrator if this condition persists. You can choose File->Work Offline to work locally until the server becomes available.
You may also find that restarting the Exchange System Attendant Service does not report the following event ID message in the Application event log when the service restarts: Event Type: Information
Event Source: MSExchangeSA
Event Category: RFR Interface
Event ID: 9070
Description: The Directory Service Referral interface (RFRI) started successfully.

CAUSE

In Exchange 2000 Service Pack 2 and later, the following services do not run on front-end servers:
  • DSProxy (RFR service and Named Service Provider Interface [NSPI] proxy)
  • Offline Address Book generation
  • The Free Busy service
  • The Recipient Update service
  • The Mailbox Clean task

RESOLUTION

Although Microsoft does not recommend that you use mailboxes on a front-end Exchange 2000 computer, Exchange 2000 SP3 has added functionality to permit this to work correctly. To resolve this problem, obtain the latest service pack for Microsoft Exchange 2000 Server. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

301378 XGEN: How to Obtain the Latest Exchange 2000 Server Service Pack

The English version of this fix should have the following file attributes or later:

Component: Administrator

File nameVersion
Exmgmt.exe6.0.5770.67
Exsp.dll6.0.5770.67
Exwmi.dll6.0.5770.67
Mad.exe6.0.5770.67

STATUS

Microsoft has confirmed that this is a problem in Microsoft Exchange 2000 Server. This problem was first corrected in Microsoft Exchange 2000 Server Service Pack 3.

MORE INFORMATION

After you apply this fix, an administrator can use a registry value to turn on DSProxy services (RFR service and NSPI Proxy) on a front-end server:
  1. Install the fix that is described in the "Resolution" section of this article.
  2. Add the Enable DSProxy Service registry value:
    1. Start Registry Editor (Regedt32.exe).
    2. Locate and click the following key in the registry:

      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeSA\Parameters

    3. On the Edit menu, click Add Value, and then add the following registry value:

      Value name: Enable DSProxy Service
      Data type: REG_DWORD
      Value data: 0x1

      If the registry value does not exist or is set to 0x0, the behavior does not change from Exchange 2000 SP2 (in other words, DSProxy is not started on a front-end server). To turn on DSProxy-related services on a front-end server, set the Enable DSProxy Service value to 0x1.
    4. Quit Registry Editor.
  3. Restart the Exchange System Attendant service.

Modification Type:MinorLast Reviewed:6/5/2003
Keywords:kbbug kberrmsg kbExchange2000preSP3fix kbExchange2000sp3fix kbfix KB319175