Session IDs Are Appended in the Name of Redirected Printers (318939)
The information in this article applies to:
- Microsoft Windows 2000 Server SP1
- Microsoft Windows 2000 Server SP2
- Microsoft Windows 2000 Advanced Server SP1
- Microsoft Windows 2000 Advanced Server SP2
- Microsoft Windows 2000 Professional SP1
- Microsoft Windows 2000 Professional SP2
This article was previously published under Q318939 IMPORTANT: This article contains information about modifying the registry. Before you
modify the registry, make sure to back it up and make sure that you understand how to restore
the registry if a problem occurs. For information about how to back up, restore, and edit the
registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows Registry
SYMPTOMS
When a client computer connects to a Windows 2000-based computer that is running Terminal Services, the client's redirected printer may contain multiple session IDs in the name.
CAUSE
This problem may occur if a race condition exists during the creation of a printer queue and listening on the printer port.
RESOLUTIONWARNING: If you use Registry Editor incorrectly, you may cause serious problems that may
require you to reinstall your operating system. Microsoft cannot guarantee that you can solve
problems that result from using Registry Editor incorrectly. Use Registry Editor at your own
risk. To resolve this problem, obtain the latest service pack for Windows 2000. For additional information, click the following article number to view the article in the
Microsoft Knowledge Base:
260910 How to Obtain the Latest Windows 2000 Service Pack
The English version of this fix should have the following file attributes or later:
Date Time Version Size File name
-----------------------------------------------------
27-Feb-2002 14:36 5.0.2195.4990 130,352 Rdpdr.sys
After you apply the hotfix on the Terminal Services computer, clear the printer client caches for all client computers. To do this:
- Remove any third-party print drivers and print monitors from the
Terminal Services computer.
- Clear all cached printers from the registry on the client computer.
Redirected printers are cached on the client computer in the following registry key:
HKEY_CURRENT_USER\Software\Microsoft\Terminal Server
Client\Default\AddIns\RDPDR\Printer STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Windows 2000 Service Pack 3.
Modification Type: | Minor | Last Reviewed: | 9/27/2005 |
---|
Keywords: | kbHotfixServer kbQFE kbbug kbenv kbfix kbprint kbTermServ kbui kbWin2000PreSP3Fix kbWin2000sp3fix KB318939 |
---|
|