XADM: Exchange System Manager Cannot Modify the File Locations of Content Index Files (318828)



The information in this article applies to:

  • Microsoft Exchange 2000 Server

This article was previously published under Q318828

SYMPTOMS

You may not be able to use Exchange System Manager to change the file location of the property store, property store logs, catalogs, gather logs, or temporary files for the content index.

CAUSE

Exchange System Manager in Exchange 2000 does not have a native mechanism to move the property store, property store logs, catalogs, gather logs, or temporary files for the content index.

WORKAROUND

To work around this behavior, you must use one or more of the following scripts or utilities or use the following registry modification to change the location of the files for the content index:
  • Use PStoreUtl.exe to change the location of the property store and the property store logs.
  • Use CatUtil.exe to change the location of the catalogs.
  • Change the path that is specified in the following registry key to change the preferred location of the gather logs:

    HKEY_LOCAL_MACHINE\Software\Microsoft\Search\1.0\gather\ExchangeServer_instance\Catalog Name\StreamLogsDirectory

  • Use SetTmpPath.exe to change the location of the temporary files.
By default, you can find PStoreUtl.exe, CatUtil.exe, and SetTmpPath.exe in C:\Program Files\Common Files\System\MSSearch\Bin.

STATUS

This behavior is by design.

MORE INFORMATION

For additional information about PStoreUtl.exe and CatUtil.exe, click the article number below to view the article in the Microsoft Knowledge Base:

294821 XADM: Recommendations for Using Content Indexing Utilities

For specific detailed instructions about how to move the content index files and more information about full-text indexing, visit the following Microsoft Web site:

Modification Type:MinorLast Reviewed:4/25/2005
Keywords:kbbug kbnofix KB318828