SYMPTOMS
When you subscribe to a document or a folder in Microsoft SharePoint
Portal Server 2001 and then try to view your subscription, you may receive the
following error message in your Web browser window:
Failed to
get subscription results for
Additionally, if you configured
SharePoint Portal Server to send you e-mail notifications about your
subscription, you do not receive any e-mail notifications.
CAUSE
This problem may occur if both of the following conditions
are true:
- SharePoint Portal Server is installed on a
Japanese version of Microsoft Windows 2000 or on an English version of Windows 2000 that is configured to use Japanese language
settings.
-and- - The folder or the document that you subscribed to is located in
a folder that uses a document profile that contains a property that uses
one or more of the following characters in its name:
- Half-width Japanese Katakana character
- Full-width double-byte character set
(DBCS) numeric character
- Blank space
- Backslash (\)
- Colon (:)
- Asterisk (*)
- Question mark (?)
- Quotation marks (")
- Angle brackets (<>)
- Tilde (~)
- Number sign (#)
- Exclamation mark (!)
- Percent sign (%)
You cannot use these characters in XML tag names. In a situation where
these characters are used in property names, SharePoint Portal Server does not
correctly verify that the characters are XML-compatible when
the property is added to the document profile for a folder. As a result, you
cannot view your subscription to the folder or the document that is contained in
the folder.
RESOLUTION
Hotfix Information
A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next SharePoint Portal Server 2001 service pack that contains this hotfix.
To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:
Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
Prerequisites
Because of file dependencies, this update requires Microsoft
SharePoint Portal Server 2001 Service Pack 1.
File Information
The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the
Time Zone tab in the Date and Time tool in Control Panel.
Date Time Version Size File name
------------------------------------------------------------------
18-Oct-2003 12:37 5.50.4134.600 655,632 Q318776_admin.exe
18-Oct-2003 12:37 5.50.4134.600 655,632 Q318776_client.exe
After the hotfix is installed, the following files have the
listed attributes or later:
Date Time Version Size File name
--------------------------------------------------------------
06-Mar-2002 18:26 625,152 Msonsext.msp
Important This fix prevents the situation that is described in the
"Symptoms" section of this article in new document profiles
that you create.
This fix does not correct existing document profiles
that contain a property that uses half-width Japanese Katakana characters,
full-width DBCS numeric characters, or other characters that cannot be used in XML tag names. For existing document profiles, you must
manually change the property name so that it does not contain any of these
characters.