A Network Adapter Is Missing in Device Manager After a Full Restore (318715)
The information in this article applies to:
- Microsoft Windows 2000 Server SP1
- Microsoft Windows 2000 Server SP2
- Microsoft Windows 2000 Advanced Server SP1
- Microsoft Windows 2000 Advanced Server SP2
- Microsoft Windows 2000 Professional SP1
- Microsoft Windows 2000 Professional SP2
This article was previously published under Q318715 SYMPTOMS
After you use Ntbackup.exe to perform a full restore or a full System State restore to restore a Windows 2000 installation over a clean Windows 2000 installation, the network adapter may be missing in Device Manager. Instead of the correct network adapter, a new device, such as a WAN miniport (L2TP) device, may be listed. You also might not be able to reinstall the network adapter.
CAUSE
This behavior can occur if the deployment method that was used to install the clean Windows 2000 installation differs from the deployment method that was used to install the original installation.
RESOLUTION
Before you perform the restore operation, you must reinstall Windows 2000 by using the same deployment method that was used to install the original installation. For example, if the original installation was installed by using the Windows 2000 CD-ROM, you must install the clean installation of Windows 2000 by using the Windows 2000 CD-ROM. If the installation was originally installed by using an unattended installation script, you must use the same script to install the clean installation. After you perform the clean installation by using the same deployment method, you can perform the restore operation.
You might also be able to work around this behavior with an in-place upgrade of Windows 2000 after you perform the restore operation. For additional information about performing an in-place upgrade, click the article number below
to view the article in the Microsoft Knowledge Base:
292175 How to Perform an In-Place Upgrade of Windows 2000
If an in-place upgrade of Windows 2000 does not correct the issue, the following workaround might resolve the issue:
- Install a secondary protocol such as the NetBEUI protocol. If you already have a secondary protocol installed, skip this step.
- If the computer is a domain controller, restart the computer in Directory Services Restore mode. Otherwise, restart the computer in "Safe Mode with Networking" mode.
- Remove the TCP/IP protocol from properties of the Local Area Connection.
- If the computer is a domain controller, restart the computer again in Directory Services Restore mode. Otherwise, restart the computer again in "Safe Mode with Networking" mode. You must restart the computer again at this stage because the TCP/IP protocol is not available for reinstallation until you restart the computer.
- Reinstall the TCP/IP protocol in the Local Area Connection properties.
- Remove the protocol that you temporarily added in step 1 (if appropriate), and then restart the computer.
Modification Type: | Major | Last Reviewed: | 12/4/2003 |
---|
Keywords: | kbenv kbprb kbsetup KB318715 |
---|
|