"The Server Threw an Exception" Error Message When User Logs in Through Site Builder (318385)



The information in this article applies to:

  • Microsoft Content Management Server 2001 SP1

This article was previously published under Q318385

SYMPTOMS

When a user starts the Site Builder and clicks the Login button, the user may receive the following error message:
The server threw an exception

CAUSE

If the user who is trying to log on does not have access to the root of the domain (that is, if the user does not have Read access for Users and Groups), Content Management Server (CMS) does not impersonate the System account user for CMS for this group membership enumeration, so the user cannot enumerate the group membership and receives an exception error message from the domain.

Note that this is not a problem when Active Directory Service (ADS) Lightweight Directory Access Protocol (LDAP) authentication is enabled. Impersonation with the System account user works correctly when ADS LDAP authentication is enabled.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Content Management Server 2001 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time      Version      Size    File name
   --------------------------------------------------------
   Jan-28-2002  19:42:32  4.1.942.108  128 KB  Aeusrmgr.dll
				
NOTE: Because of file dependencies, this update requires Microsoft Content Management Server 2001 Service Pack 1.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:10/10/2005
Keywords:kbHotfixServer kbQFE kbbug kbContentMgtServ2001preSP2fix kbfix KB318385