"An Invalid Operation Was Attempted on an Active Network Connection" Error Message Occurs If You Try to Browse the Network (318245)
The information in this article applies to:
- Microsoft Windows XP Professional
- Microsoft Windows 2000 Server
- Microsoft Windows 2000 Advanced Server
- Microsoft Windows 2000 Professional
- Microsoft Small Business Server 2000
This article was previously published under Q318245 SYMPTOMS
If you use a Windows 2000 Professional-based or a Windows XP Professional-based client computer to browse the network, you may receive the following error message, where Domain is the name of your domain:
Domain is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.
An invalid operation was attempted on an active network connection.
If you remove the client computer from the domain, and then add it to a workgroup that has the same name as the domain, you may no longer experience this behavior. If you turn off the Trend Micro antivirus service on the server, you may no longer experience this behavior.
CAUSE
This behavior may occur if the Trend Micro OfficeScan Corporate Edition antivirus program is installed on the client computers in the domain.
RESOLUTION
To resolve this behavior, obtain and install the update to the Trend Micro OfficeScan filter (Tmfilter.sys).
How to Obtain the Update to the Trend Micro OfficeScan Filter
To obtain the update to the Trend Micro OfficeScan filter (Tmfilter.sys, file version 5.63.1005), contact Trend Micro to obtain the update. To contact Trend Micro, see the following Trend Micro Web site:
Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information. How to Install the Update on a Single Client Computer
Install the updated Trend Micro OfficeScan filter on one client computer to test the filter before you apply the changes across the network.
NOTE: Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps. - Log on to the client computer as an administrator.
- Click Start, point to Settings, and then click Control Panel.
- Double-click Administrative Tools, and then double-click Services.
- Right-click OfficeScanNT Listener, click Stop, right-click OfficeScanNT Realtime Scan, and then click Stop.
- Extract the contents of the new Tmfilter.zip file (Tmfilter.sys, file version 5.63.1005) to the OfficeScanNT folder.
- In the Services tool, right-click OfficeScanNT Listener, click Start, right-click OfficeScanNT Realtime Scan, and then click Start.
- Try to browse the network.
If you can successfully browse the network from the updated client computer, install the update on the server that is running OfficeScan. The update is automatically deployed to all client computers.
How to Install the Update on the Server That Is Running OfficeScan
To install the update on the server, follow these steps.
NOTE: Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps. - Log on to the server as an administrator.
- Click Start, point to Settings, and then click Control Panel.
- Double-click Administrative Tools, and then double-click Services.
- Verify that the OfficeScan Master Service is running.
If this service is stopped, right-click the service, and then click Start. - Start Microsoft Windows Explorer, and then locate the following folder, where Share is the shared network folder that you configured when you installed Trend Micro OfficeScan.
Share\PCCSRV\Admin\Utility\Touch
- In the right pane of Windows Explorer, right-click Touch.exe, and then click Copy.
- Locate the following folder, where Share is the shared network folder that you configured when you installed Trend Micro OfficeScan:
- On the Edit menu, click Paste.
- Quit Windows Explorer.
- Extract the contents of the new Tmfilter.zip file (Tmfilter.sys, file version 5.63.1005) to the Share\Pccsrv\Temp folder.
The Temp folder contains the following two files:
- Click Start, click Run, type cmd in the Open box, and then click OK.
- At the command prompt, change to the Share\Pccsrv\Temp folder (where Share is the shared folder that you created when you installed OfficeScan), and then press ENTER.
For example, type cd\share\pccsrv\temp, and then press ENTER. - Type touch tmfilter.sys, and then press ENTER.
- Start Windows Explorer, and then copy Tmfilter.sys from the Share\Pccsrv\Temp folder to the Share\Pccsrv\Pccnt\Drv folder.
- When you are prompted to replace the existing file, click Yes to confirm the replacement.
- Locate the Share\Pccsrv\Download folder.
After a short period of time (between 5 and 10 minutes), a file named Hotfixnt.txt appears in this folder. The updated Tmfilter.sys file is automatically deployed to the client computers.
NOTE: The OfficeScan NT Listener service must be running on the client computers for the Tmfilter.sys file to be automatically updated. - After the Tmfilter.sys file is updated on the client computers (the OfficeScan RealtimeScan service restarts when the file has been updated), try to browse the network from the client computers to confirm that the update was successful.
The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.
Modification Type: | Major | Last Reviewed: | 2/9/2004 |
---|
Keywords: | kbprb KB318245 |
---|
|