An Error Occurs in Mshtml.dll in Internet Explorer 6 on Windows Me (318153)



The information in this article applies to:

  • Microsoft Internet Explorer version 6 for Windows Millennium Edition

This article was previously published under Q318153

SYMPTOMS

While you are using Internet Explorer 6, you may receive the following error message:
Iexplore.exe has encountered a problem and needs to close. We are sorry for the inconvenience.
If you view the data that the error report contains, the following error signature information is listed:

App name       App version   Module name   Module version   Offset
-------------------------------------------------------------------
Iexplore.exe   6.0.2600.0    Mshtml.dll    5.50.4134.100    Various
					

CAUSE

Internet Explorer 6 requires Mshtml.dll version 6.0.2600.0. The error message may occur if you are using a different version of Mshtml.dll. An incorrect version of this dynamic-link library (DLL) can cause an access violation.

RESOLUTION

Method 1

To resolve this issue, reinstall Internet Explorer 6. You can obtain Internet Explorer 6 from the following Microsoft Web site:

Method 2

Re-extract Mshtml.dll from the Internet Explorer version 6 cabs. To do so, follow the steps listed for your operating system:

Microsoft Windows 98

  1. Click Start, click Run, type sfc, and then click OK.
  2. Click Extract one file, type ie_1.cab, and then click Start.
  3. In the Restore from field, type c:\windows\windows update setup files.
  4. In the Save as field, type c:\windows\windows update setup files, and then click OK.
  5. When you receive a prompt to back up the file to C:\Windows\Helpdesk\Sfc, click Yes or OK.
  6. If you receive the following prompt, click Yes or OK:

    The backup folder does not exist. Do you want to create it?

  7. If you receive a dialog box that says: "The file was successfully extracted", click OK.
  8. Click Start, click Run, type sfc, and then click OK.
  9. Click Extract one file, type mshtml.dll, and then click Start.
  10. In the Restore from field, type c:\windows\windows update setup files.
  11. In the Save as field, type c:\windows\system, and then click OK.
  12. When you receive a prompt to back up the file to C:\Windows\Helpdesk\Sfc, click Yes or OK.
  13. When you receive a dialog box that says: "The file was successfully extracted", click OK.
  14. Close System File Checker and then restart the computer.

Microsoft Windows Millennium Edition (Me)

  1. Click Start, click Run, type msconfig, and then click OK.
  2. Click Extract.
  3. Type ie_1.cab, and then click Start.
  4. In the Restore from field, type c:\windows\windows update setup files.
  5. In the Save as field, type c:\windows\windows update setup files, and then click OK.
  6. When you receive a prompt to back up the file to C:\Windows\Helpdesk\Sfc, click Yes or OK.
  7. If you receive the following prompt, click Yes or OK:

    The backup folder does not exist. Do you want to create it?

  8. If you receive a dialog box that says: "The file was successfully extracted", click OK.
  9. Click Start, click Run, type msconfig, and then click OK.
  10. Click Extract
  11. Type mshtml.dll, and then click Start.
  12. In the Restore from field, type c:\windows\windows update setup files.
  13. In the Save as field, type c:\windows\system, and then click OK.
  14. When you receive a prompt to back up the file to C:\Windows\Helpdesk\Sfc, click Yes or OK.
  15. When you receive a dialog box that says: "The file was successfully extracted", click OK.
  16. Close System File Checker and then restart the computer.

MORE INFORMATION

You can look for later versions of Internet Explorer by checking either of the following Microsoft Web sites:

Modification Type:MajorLast Reviewed:11/5/2003
Keywords:kbprb kbProd2Web KB318153