Black screen on startup after you upgrade to Windows XP Professional (318031)



The information in this article applies to:

  • Microsoft Windows XP Professional

This article was previously published under Q318031

SYMPTOMS

After you upgrade your Microsoft Windows XP Home Edition-based computer to Microsoft Windows XP Professional, you may experience one or more of the following behaviors:
  • When you start the computer, the display turns black with a large white pointer.
  • You cannot increase the screen resolution to higher than 640 × 480 pixels.
  • You receive the following error message when Windows starts:
    \\.\DRI_KBFiltr
    The System cannot find the file specified.

CAUSE

These behaviors may occur if you upgrade a Hewlett Packard Pavilion N5495 portable computer.

RESOLUTION

To resolve this issue, follow these steps.

Step 1: Restart Windows in safe mode

  1. Restart the computer. After the Power On Self Test (POST), press the F8 key.
  2. On the Windows Advanced Options Menu, use the ARROW keys to select Safe Mode, and then press ENTER.
  3. If you are prompted to select the operating system to start, select Microsoft Windows XP edition (where edition is the edition of Windows XP that is installed), and then press ENTER.
  4. On the To begin, click your user name page, click Administrator.
  5. Type the administrator password, and then click the arrow button.

    Note In some cases, the Administrator password may be set to a blank password. In this case, do not type a password before you click the arrow button.
  6. Click Yes to close the message that states that Windows is running in safe mode.

Step 2: Turn off the secondary display adapter

  1. Click Start, right-click My Computer, and then click Manage.
  2. In the left pane of the Computer Management snap-in, click Device Manager.
  3. In the right pane of the Computer Management snap-in, expand Display adapters.
  4. Under Display adapters, right-click Intel(R) 830M Graphic Controller-1, and then click Disable.
  5. Click Yes to confirm, and then quit the Computer Management snap-in.
  6. Restart the computer normally.

Step 3: Reinstall the secondary display adapter

  1. Click Start, right-click My Computer, and then click Manage.
  2. In the left pane of the Computer Management snap-in, click Device Manager.
  3. In the right pane of the Computer Management snap-in, right-click Unknown display adapter under Other devices, and then click Uninstall.
  4. Click OK to confirm the device removal.
  5. If you are prompted to restart the computer, click No.
  6. On the Action menu, click Scan for hardware changes. Windows should correctly identify the display adapter as an Intel 830 Graphics Controller.
  7. Restart the computer.
  8. Log on to Windows as Administrator, and then insert the Hewlett Packard Recovery CD-ROM.
  9. Right-click Start, and then click Explore.
  10. Locate the following folder on the Hewlett Packard Recovery CD:

    \HP\DRIVERS\VIDEO

  11. Double-click Setup.exe to start the InstallShield Wizard.
  12. Follow the instructions to install the Hewlett Packard display drivers, and then restart the computer.

Step 4: Remove HP One Touch program

If you receive the following error message when Windows starts, your HP One Touch program may require an updated driver:
\\.\DRI_KBFiltr
The System cannot find the file specified.
To work around this issue, remove the HP One Touch program. To do this, follow these steps:
  1. Click Start, click Control Panel, click Switch to Classic View, and then double-click Add or Remove Programs.
  2. In the Currently installed programs list, click HP One Touch, and then click Change/Remove.
  3. Follow the instructions that appear on your screen to remove the program.
  4. If you are prompted to restart the computer, click Yes.
  5. Contact Hewlett Packard for an update to the HP One Touch program. To view a list of updates for the HP Pavilion N5495 portable computer, visit the following Hewlett Packard Web site:

MORE INFORMATION

This issue is caused by an incorrect detection of the secondary display controller during the upgrade to Windows XP Professional. To work around this issue and to successfully upgrade this computer from Windows XP Home Edition to Windows XP Professional, follow these steps.

Step 1: Delete the Undo_guimode.txt file

Delete the Undo_guimode.txt file (whose path is C:\Windows\System32\Undo_guimode.txt). To do this, follow these steps:
  1. Click Start, and then click Search.
  2. On the Tools menu, click Folder Options.
  3. Click the View tab, click Show hidden files and folders, clear the Hide extensions for known file types check box, click Apply, and then click OK.
  4. In the Search Companion pane, click All files and folders.
  5. In the All or part of the file name box, type undo_guimode.txt.

    Note There is an underscore character (_) between "undo" and "guimode.txt".
  6. In the Look in list, click Local Hard Drives, and then click Search.
  7. In the right pane of the Search Results dialog box, right-click Undo_guimode.txt, and then click Delete.
  8. Click Yes to confirm.
  9. Close the Search Results dialog box.

Step 2: Turn off the secondary display adapter

  1. Click Start, right-click My Computer, and then click Manage.
  2. In the left pane of the Computer Management snap-in, click Device Manager.
  3. In the right pane of the Computer Management snap-in, expand Display adapters.
  4. Under Display adapters, right-click Intel(R) 830M Graphic Controller-1, and then click Disable.
  5. Click Yes to confirm, and then quit the Computer Management snap-in.
  6. Restart the computer normally, and then open Device Manager to verify that the secondary display adapter is disabled. A red X appears over the device icon when it is disabled.

Step 3: Upgrade to Windows XP Professional

  1. Insert the Windows XP Professional CD, and then upgrade the computer to Windows XP Professional. When the Windows Setup program is almost completed, you receive a message that is similar to the following message:

    To improve the appearance of visual elements, Windows will automatically adjust your screen resolution.

    When you click OK, the display turns black until the Setup program is completed (a theme plays when the Windows Setup program is completed).
  2. Restart the computer.

    The Windows desktop appears as you expect.

    You may receive the following error message when you start Windows:
    \\.\DRI_KBFiltr
    The System cannot find the file specified.
  3. If you receive this error message, remove the HP One Touch program. Contact Hewlett Packard for an updated version of this program. To view a list of updated drivers for the HP Pavilion N5495 portable computer, visit the following Hewlett Packard Web site:

Step 4: Turn on the secondary display adapter

  1. Click Start, right-click My Computer, and then click Manage.
  2. In the left pane of the Computer Management snap-in, click Device Manager.
  3. In the right pane of the Computer Management snap-in, expand Display adapters.
  4. Under Display adapters, right-click Intel(R) 830M Graphic Controller-1, and then click Enable.
  5. Restart the computer.
Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MajorLast Reviewed:5/19/2004
Keywords:kberrmsg kbprb KB318031