COM+ 1.0 MSI Application Proxy Installation May Fail on Windows XP-based Client Computer (317996)



The information in this article applies to:

  • Microsoft COM+ 1.5, when used with:
    • the operating system: Microsoft Windows XP

This article was previously published under Q317996

SYMPTOMS

When you use the Component Services snap-in to create a COM+ 1.0 Microsoft Installer (MSI) application proxy remotely from a Windows XP-based computer, the installation of this Microsoft Windows 2000 COM+ server application proxy may fail. Additionally, the following events are logged in the event log:
Event Log Type : Information
Source : MSIInstaller
Event : 11708
Description :
Product: BusinessApp (Application Proxy) -- Installation operation failed. For more information, see Help and Support Center at http://support.microsoft.com.

-and-

Event Log Type : Error
Source : MSIInstaller
Event : 11928
Description :
Product: BusinessApp (Application Proxy) -- Error 1928. Error registering COM+ Application. Contact your support personnel for more information. For more information, see Help and Support Center at http://support.microsoft.com.

CAUSE

This problem occurs because the service name field of the .msi file that you created is an empty string, which confuses the application logic table parser.

RESOLUTION

To resolve this problem, obtain Microsoft XP COM+ Hotfix Rollup 1. For additional information, click the article number below to view the article in the Microsoft Knowledge Base:

317926 INFO: Availability of Windows XP COM+ Hotfix Rollup Package 1

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.


WORKAROUND

To work around this problem, create the .msi application proxy locally on the Windows 2000-based computer. The .msi application proxy installation will succeed on the Windows XP-based client computer.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

For additional information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the article number below to view the article in the Microsoft Knowledge Base:

265173 The Datacenter Program and Windows 2000 Datacenter Server Product

For additional information about how to install multiple hotfixes with only one reboot, click the article number below to view the article in the Microsoft Knowledge Base:

296861 Use QChain.exe to Install Multiple Hotfixes with One Reboot


Modification Type:MajorLast Reviewed:9/20/2006
Keywords:kbbug kbfix kbQFE kbWin2000PreSP3Fix KB317996