Event ID 2009 May Be Logged on Windows NT 4.0-Based Print Servers (317919)
The information in this article applies to:
- Microsoft Windows NT Server 4.0 SP6a
This article was previously published under Q317919 SYMPTOMS
If you are using a Windows NT 4.0-based print server with Microsoft Windows
2000-based client computers, you may see the following event logged in the System Event Log on the print server:
Event Type: Error
Event Source: Srv
Event Category: None
Event ID: 2009
User: N/A
Description: The server could not expand a table because the table reached the maximum size.
Data:
0000: 00040000 00540001 00000000 c00007d9
0010: 00000000 c000009a 00000000 00000000
0020: 00000000 00000000 000003e9
The print server may also stop responding (hang).
CAUSE
This issue can occur if the Windows 2000-based client has a Hewlett-Packard DeskJet 900-series printer installed and is connected to a shared printer on the print server. An issue with the DeskJet 900-series printer drivers causes the client to open thousands of opened named pipes to the server which overwhelms the Windows NT 4.0-based server and causes the server to hang and log event ID 2009s.
Note that this issue may also occur with Hewlett Packard OfficeJet G and Hewlett Packard OfficeJet K series printers.
RESOLUTION
To resolve this issue, obtain the latest drivers for the DeskJet 900-series printer. Hewlett-Packard has also released upgraded files for the OfficeJet printers to resolve this issue:
To resolve this issue, you can also upgrade the print server to Microsoft Windows 2000 Server. Windows 2000 has a much higher threshold for open named pipes than Windows NT 4.0 because Windows NT 4.0 has a limitation of 2,048 concurrent open files. Windows 2000 has a limit of 16,384 concurrent open files.
Modification Type: | Major | Last Reviewed: | 3/29/2002 |
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Keywords: | kbenv kberrmsg kbprb kbprint KB317919 |
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