Setup Stops Responding (Hangs) During File Copy (317512)



The information in this article applies to:

  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Small Business Server 2003, Standard Edition
  • Microsoft Windows Small Business Server 2003, Premium Edition

This article was previously published under Q317512
For a Microsoft Windows XP version of this article, see 296814.

SYMPTOMS

When you attempt to install Microsoft Windows Server 2003, Setup may appear to stop responding (hang), and you may receive the following message:

Please wait while Setup copies files to your hard disk.

CAUSE

This behavior can occur if both of the following conditions are true:
  • You start Windows Server 2003 Setup from a command prompt (MS-DOS).

    -and-
  • You do not load the SmartDrive tool (Smartdrv.exe) before you run the Winnt.exe utility, or you load Smartdrv.exe by using one of the following switches:
    • /x
    • /c
    • /l
    • InitCacheSize
    • WinCacheSize
    • /E:1024

RESOLUTION

To resolve this issue, run the smartdrv command without any switches. You may have to modify the Autoexec.bat file to remark the entry for SMARTDRV, and then run SmartDrive manually.

Note If you do not load the SmartDrive tool, or you do load the SmartDrive tool and include command-line switches, the delay can be as long 4 hours. If you do load the SmartDrive tool with no switches, there will still be a brief delay of approximately 45 seconds.

MORE INFORMATION

For more information about how to use switches with smartdrv, use a command prompt to access the drive where you loaded the SmartDrive tool, and then type smartdrv /?.

Modification Type:MajorLast Reviewed:3/1/2004
Keywords:kbprb KB317512