PRB: LDAP Service Stops Responding After You Apply Q264684i.exe Security Patch (317497)



The information in this article applies to:

  • Microsoft Site Server 3.0, when used with:
    • the operating system: Microsoft Windows NT 4.0

This article was previously published under Q317497

SYMPTOMS

After you apply the patch that is available in the following Microsoft Knowledge Base article, the Site Server 3.0 Lightweight Directory Access Protocol (LDAP) server may stop responding (hang) on startup if the Messenger and Plug and Play services are disabled:

264684 Patch for 'Remote Registry Access Authentication' Vulnerability

The following three errors are written to the System event log:
EventID 481
Source LDAPSVC
Site Server LDAP Service cannot initialize the following object: GetLastError()=-2146893792 : Init LdapExtension.
EventID 2500
Source LDAPSVC
The server failed to start due to an initialization error. Verify the configuration. Error description is: GetLastError()=-2146893792 : StaticStore.
EventID 7022
Source LDAPSVC
The Site Server LDAP Service service hung on starting.
NOTE: This patch is included in the Windows NT 4.0 Service Pack 6a Security Rollup Package (SRP), which is available through the following Knowledge Base article:

299444 Post-Windows NT 4.0 Service Pack 6a Security Rollup Package (SRP)

CAUSE

The Microsoft SQL Server driver assumes that the NetBIOS service is started. If this service is not started, the LDAP service stops responding when it tries to access the remote SQL Server database. After you install the patch, the only way to have the NetBIOS service start automatically is to have the Messanger or Plug and Play services start automatically.

RESOLUTION

To resolve this problem, change the Start parameter to Automatic on the NetBIOS service, and then restart the LDAP server. To do this, follow these steps:
  1. Start Registry Editor (Regedit.exe).
  2. Under the following registry key, select the Start value:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NetBIOS

  3. On the Edit menu, click Modify.
  4. For Value data, type 1, and then click OK.
  5. Quit Registry Editor.
  6. Restart the LDAP server.

STATUS

Microsoft has confirmed that this is a problem in Site Server version 3.0.

MORE INFORMATION

Steps to Reproduce Behavior

  1. On a Windows NT 4.0 Server computer, install Windows NT 4.0 Service Pack 3.
  2. Install Internet Explorer 4.01 Service Pack 2.
  3. Install the Windows NT 4.0 Option Pack.
  4. Install the SQL Server client configuration (Windbver.exe).
  5. Install Site Server 3.0.
  6. Install Windows NT 4.0 Service Pack 4.
  7. Install Microsoft Data Access Components (MDAC) 2.1 Service Pack 2.
  8. Install Active Directory Services Interfaces (ADSI) 2.5.
  9. Install Site Server 3.0 Service Pack 4.
  10. Install Windows NT 4.0 Service Pack 6a.
  11. Configure SQL Server access to the LDAP root database on an external SQL server.
  12. Apply the patch.
  13. Disable Messenger and Plug and Play.

Modification Type:MajorLast Reviewed:2/4/2002
Keywords:kbprb KB317497