Outlook 2002 and Outlook 2003 do not call MAPI transports when you work offline (317412)



The information in this article applies to:

  • Microsoft Office Outlook 2003
  • Microsoft Outlook 2002

This article was previously published under Q317412
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you try to send a message using a third-party transport provider in Offline mode in Microsoft Outlook 2002 or in Microsoft Office Outlook 2003, the SubmitMessage() function of that transport provider is not called and the message remains in the Outbox until you click Send/Receive.

CAUSE

This problem occurs because Outlook has redesigned its use of the MAPI spooler. The Mapisp32.exe file process is no longer used in Outlook. With the new design, the Outlook Protocol Manager (OPM) calls the MAPI Protocol Handler (MPH), which then calls each of the MAPI transports as needed.

There is not a way for the transport to programmatically control the Send/Receive function with the new design in Outlook because the OPM is in control of this functionality.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

304116 Custom MAPI transport providers may not function in Outlook 2003 and in Outlook 2002

RESOLUTION

To resolve this problem, obtain the latest service pack for Microsoft Office XP. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

307841 How to obtain the latest Office XP service pack

After you apply the fix, add the following registry setting so that the transport provider loads immediately when you start Outlook.

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
  1. Click Start, and then click Run.
  2. In the Open box, type regedit.exe, and then click OK.
  3. Locate and then click the following key in the registry.

    Outlook 2002

    HKCU\Software\Microsoft\Office\10.0\Outlook\Preferences

    Outlook 2003

    HKCU\Software\Microsoft\Office\11.0\Outlook\Preferences

  4. On the Edit menu, click Add Value, and then add the following registry value:

    Value name:PollTransportOffline
    Data type: DWORD
    Value data: 1

  5. Close Registry Editor.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:3/15/2006
Keywords:kbHotfixServer kbQFE kbbug kbfix kbOfficeXPPreSP2fix KB317412