"Error Loading Driver" Error Message When You Open Display Properties Dialog Box (317128)
The information in this article applies to:
- Microsoft Windows NT Workstation 4.0
- Microsoft Windows NT Server 4.0
This article was previously published under Q317128 IMPORTANT: This article contains information about modifying the registry. Before you
modify the registry, make sure to back it up and make sure that you understand how to restore
the registry if a problem occurs. For information about how to back up, restore, and edit the
registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows Registry
SYMPTOMS
When you open Control Panel and then double-click the Display icon, you may receive the following error message:
Error loading driver.
You may be unable to open the Display Properties dialog box.
CAUSE
This behavior can occur if your computer contains a corrupted or incompatible third-party PropertySheetHandlers registry key. The registry key may become corrupted or incompatible if you install or upgrade a third-party display driver.
RESOLUTION
To resolve this issue, export and then remove third-party PropertySheetHandlers registry keys. To do this, follow these steps. WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may
require you to reinstall your operating system. Microsoft cannot guarantee that you can solve
problems that result from using Registry Editor incorrectly. Use Registry Editor at your own
risk. - Click Start, and then click Run.
- In the Open box, type regedit, and then click OK.
- Navigate to the following registry subkey:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion
\Controls Folder\Display\shellex\PropertySheetHandlers - On the Registry menu, click Export Registry File.
- In the File name box, type propertysheethandlers registry key, and then click Save.
NOTE: You can undo the registry changes that follow by double-clicking the propertysheethandlers registry key.reg file. - Click the PLUS (+) sign next to the PropertySheetHandlers subkey to expand it.
- Under the PropertySheetHandlers subkey, click the chipset CPL Extension subkey, where chipset is the chipset of your display adapter. For example, if you have an SIS chipset-based display adapter, click the SIS CPL Extension registry key.
- On the Edit menu, click Delete.
- When you receive a message that prompts you to confirm the key deletion, click Yes.
- Under the PropertySheetHandlers subkey, click the PlusPack CPL Extentsion subkey.
- On the Edit menu, click Delete.
- When you receive a message that prompts you to confirm the key deletion, click Yes.
- On the Registry menu, click Exit.
- Restart the computer.
- Reinstall the drivers for your display adapter.
NOTE: If this issue occurred after you upgraded your display drivers, attempt to install an earlier driver with which you did not experience the behavior.
Modification Type: | Major | Last Reviewed: | 8/6/2002 |
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Keywords: | kberrmsg kbprb KB317128 |
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