An Update Is Available for BackOffice Server 4.0 and 4.5 for Logging On (316838)



The information in this article applies to:

  • Microsoft BackOffice Server 4.0
  • Microsoft BackOffice Server 4.5

This article was previously published under Q316838

SYMPTOMS

An update is available for the BackOffice Web Administrator component of BackOffice Server versions 4.0 and 4.5. This update is for installations in which the default security settings have been changed. If the default security settings for the Boadmin virtual folder have been changed, apply this update to avoid a possible security risk.

Mitigating factors:
  • The issue occurs only if basic authentication is being used for the virtual Boadmin folder under the Default Web site in Microsoft Internet Information Server (IIS).
  • By default, BackOffice Web Administrator is configured to accept connections only from Localhost (127.0.0.1). This prevents users who do not have Log on Locally permissions from accessing the Web page, but does not completely prevent the risk that is mentioned in this article.

CAUSE

The issue occurs because users can bypass the logon screen (Boadmin\Backoffice\Services.asp) if an authorization type (auth_type) other than "" is entered as part of an HTTP request.

RESOLUTION

The following file is available for download from the Microsoft Download Center:
Release Date: April 2, 2002

For additional information about how to download Microsoft Support files, click the following article number to view the article in the Microsoft Knowledge Base:

119591 How to Obtain Microsoft Support Files from Online Services

Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help to prevent any unauthorized changes to the file.

The English version of this fix should have the following file attributes or later:
   Date         Time   Size    File name
   ---------------------------------------
   11-Jan-2002  23:34  19,965  Include.asp
				

WORKAROUND

To prevent the issue that is mentioned in this article from occurring, download the fix that is mentioned in the "Resolution" section of this article, or use the following procedure:
  1. Open the Boadmin\Backoffice\Services.asp file in Notepad.
  2. Locate the following lines:

    If Request.ServerVariables("auth_type") = "" Then
    Response.Status = "401 ACCESS DENIED"
    Response.End
    End If

  3. Replace the lines that you located with the following lines:

    If Request.ServerVariables("LOGON_USER") = "" Then
    Response.Status = "401 ACCESS DENIED"
    Response.End
    End If
    response.write "Welcome"

  4. Save the Services.asp file.
  5. Stop and the restart the default Web site.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

If you do not use the BackOffice Web Administrator component to manage your BackOffice server, you can safely delete the Web site from your BackOffice server. To do this:
  1. Click Start, point to Programs, point to Windows NT 4.0 Option Pack, point to Microsoft Internet Information Server, and then click Internet Service Manager.
  2. Expand your default Web site, and then locate the Boadmin entry.
  3. Click the Boadmin virtual folder to select it. Right-click the virtual folder entry, and then click Delete. When you are prompted to verify that you want to delete the item, click Yes.
Acknowledgment: David Litchfield of NGSSoftware contributed to this Microsoft Knowledge Base article.

Modification Type:MinorLast Reviewed:9/27/2005
Keywords:kbHotfixServer kbQFE kbbug kbenv kbfix KB316838 kbAudDeveloper