Error Message: IEXPLORE Caused an IPF in Module Mailcom.dll (316514)



The information in this article applies to:

  • Microsoft Windows Millennium Edition
  • Microsoft Windows 98 Second Edition
  • Microsoft Windows 98

This article was previously published under Q316514

SYMPTOMS

When you try to use Microsoft Internet Explorer and MSN Internet Access to browse the Internet, you may receive an error message similar to the following:
IEXPLORE caused an invalid page fault in module mailcom.dll.

CAUSE

This problem can occur if the Mailcom.dll file is damaged.

RESOLUTION

To resolve this problem, use one of the following methods to replace Mailcom.dll:

Download the Latest Version

NOTE: Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.
  1. Click Start, point to Find, and then click Files or Folders.
  2. In the Named box, type Mailcom.dll, and then click Find Now.
  3. In the Search Results list, right-click Mailcom.dll, and then click Rename.
  4. Type Mailcom.old, and then press ENTER.
  5. Browse to the MSN Web site:http://explorer.msn.com/home.htm

  6. Click Install, and then follow the prompts to install the latest version of MSN.

Extract the File from a Windows CD-ROM

Replace the file with a new copy from your Windows installation disc. To do this, use the method for your operating system as follows.

Windows Millennium Edition

  1. Click Start, point to Search, and then click For Files or Folders.
  2. In the Search for files or folders named box, type Mailcom.dll, and then click Search Now.
  3. In the Search Results list, right-click Mailcom.dll, and then click Rename.
  4. Type Mailcom.old, and then press ENTER. Close the Search Results dialog box.
  5. Click Start, and then click Run.
  6. In the Open box, type Msconfig, and then click OK.
  7. In the System Configuration Utility, on the General tab, click Extract File.
  8. In the Specify the system file you would like to restore box, type Mailcom.dll, and then click Start.
  9. In the Restore from box, browse to the location of your Windows Millennium Edition CD.

    NOTE: If you have an original equipment manufacturer (OEM) installation of Windows Millennium Edition, the Windows installation files may be stored in the following location:

    C:\WINDOWS\OPTIONS\INSTALL

  10. In the Save file in box, type C:\Program Files\Msnia, and then click OK.
  11. Click OK when the file is extracted, and then restart the computer.

Windows 98

  1. Click Start, point to Find, and then click Files or Folders.
  2. In the Named box, type Mailcom.dll, and then click Find Now.
  3. In the Search Results list, right-click Mailcom.dll, and then click Rename.
  4. Type Mailcom.old, and then press ENTER.
  5. Click Start, and then click Run.
  6. In the Open box, type SFC, and then click OK.
  7. In the System File Checker dialog box that appears, click Extract one file from installation disk.
  8. In the Specify the system file you would like to restore box, type Mailcom.dll, and then click Start.
  9. In the Restore from box, browse to your Windows 98 installation CD.

    NOTE: If you have an original equipment manufacturer (OEM) installation of Windows 98, the Windows installation files may be stored in the following location:

    C:\Windows\Options\Cabs

  10. In the Save file in box, type C:\Program Files\Msnia, and then click OK.
  11. After the file is extracted, click OK, and then restart the computer.

MORE INFORMATION

For additional information about extracting files, click the article number below to view the article in the Microsoft Knowledge Base:

129605 How to Extract Original Compressed Windows Files


Modification Type:MinorLast Reviewed:12/20/2004
Keywords:kberrmsg kbInvalidPageFault kbprb ocsso KB316514