PRB: BizTalk Document Tracking Interface Does Not Work from Clients with MDAC 2.5 Installed (316294)



The information in this article applies to:

  • Microsoft BizTalk Server 2000
  • Microsoft BizTalk Server 2002

This article was previously published under Q316294

SYMPTOMS

If you try to connect to a Microsoft BizTalk document tracking database with the Document Tracking user interface from a client computer that is not running Microsoft BizTalk Server or Microsoft SQL Server, you may receive the following error message:
[DBNMPNTW]ConnectionOpen (CreateFile())

CAUSE

This error is caused by the client computer trying to connect to a named instance of SQL Server. The Document Tracking user interface can connect to a named instance of SQL Server if BizTalk is configured to work with a SQL Server cluster. The Document Tracking user interface can connect to a named instance of SQL Server if the BizTalk databases are hosted on one instance of a multiple-instance setup of SQL Server.

This type of connection requires Microsoft Data Access Components (MDAC) 2.6 or later.

RESOLUTION

To work around this issue:
  • Upgrade the client computer to at MDAC 2.6 or later.

    -or-
  • Define a SQL Server alias with the SQL Server Client Network utility:
    1. Create a SQL Server alias. To do so, follow the instructions in following Microsoft Knowledge Base article:

      265808 INF: How to Connect to a SQL Server 2000 Named Instance with the Previous Version's Client Tools

    2. Run the Client Network utility:
      • If you have SQL Server connectivity or tools only installed, start the utility from the Start menu.
      • If you do not have SQL Server tools installed, click Start, click Run, type cliconfg.exe, and then click OK.

MORE INFORMATION

To access the Document tracking interface, direct your browser to the following URL where BizTalkServer is the name of your BizTalk Server:

http://BizTalkServer/BizTalkTracking/


Modification Type:MajorLast Reviewed:6/4/2003
Keywords:kbfix kbprb KB316294