Connection to SMS Provider Without Impersonation May Cause the Wrong User Groups to Be Retrieved (316258)
The information in this article applies to:
- Microsoft Systems Management Server 2.0 SP3
This article was previously published under Q316258 SYMPTOMS
When you are using a program that does not set the WBEM security level to Impersonate (wbemImpersonationLevelImpersonate (3)) during a
connection to the Systems Management Server (SMS) provider, the SMS provider may obtain the incorrect user groups to which that user belongs. The user may then have more or less access rights in a running SMS Administration console (or program that uses the SMS SDK) than is defined in the SMS Security rights.
CAUSE
The SMS Provider is incorrectly dealing with provider connections which are not setting the DCOM security level to Impersonate.
RESOLUTIONService Pack Information To resolve this problem, obtain the latest service pack for Microsoft Systems Management Server 2.0. For additional information, click the following article number to view the article in the Microsoft Knowledge Base: 288239 How to Obtain the Latest Systems Management Server 2.0 Service Pack Hotfix InformationA supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Systems Management Server service pack that contains this hotfix. To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site: NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
The hotfix originally provided for the problem that is described in this Microsoft Knowledge Base article is no longer available. The hotfix for the following Microsoft Knowledge Base article now supercedes it.
For additional information, click the article number below
to view the article in the Microsoft Knowledge Base:
324204 SMS: Collections That Are Based on Complex Queries Do Not Update
If you want to resolve the problem that is described in this article, you must install the hotfix for Microsoft Knowledge Base article Q324204.
WORKAROUND
To work around this problem, always set the WBEM authentication level to Impersonate in any program or script that connects to the SMS provider.
If you are using the WMI Scripting API, verify that the registry on the computer that is running the script has a default impersonation level set in the registry:
- Start Registry Editor (Regedt32.exe).
- Locate the Default Impersonation Level value under the following key in the registry:
HKEY_LOCAL_MACHINE\Software\Microsoft\WBEM\Scripting - Verify that the REG_DWORD value is set to 0x3.
- Quit Registry Editor.
If the SMS Service account has security rights in the SMS Administrator console by way of account or group membership, either remove or restrict the rights as it is the group membership for this account which may be incorrectly checked for access.
STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Microsoft Systems Management Server 2.0 Service Pack 5.
Modification Type: | Minor | Last Reviewed: | 10/11/2005 |
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Keywords: | kbHotfixServer kbQFE kbSMS200preSP5fix kbSecurity kbbug kbenv kberrmsg kbfix kbsmsProvider KB316258 |
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