PRB: You Cannot View Trading Partners in the Trading Partner Management Module of Commerce Server Business Desk (316012)



The information in this article applies to:

  • Microsoft BizTalk Accelerator for Suppliers, version 1.0

This article was previously published under Q316012

SYMPTOMS

When you attempt to create a trading partner profile in the Trading Partner Management module of the Microsoft Commerce Server Business Desk, there are no BizTalk Transport Channels listed. This behavior occurs if you install BizTalk Accelerator for Suppliers with BizTalk Server 2002.

CAUSE

This problem occurs because the Microsoft Commerce Server 2000 Business Desk and the Microsoft BizTalk Server 2002 Trading Partner database use different Microsoft SQL Server security architectures. Because of this difference, the user context in which the Business Desk is running cannot be properly authenticated to retrieve the channel information from the BizTalk Server 2002 database.

RESOLUTION

To resolve the problem of the security architecture difference between Commerce Server 2000 and BizTalk Server 2002, you need to grant the proper user account access to the SQL Server database.

To grant the user account the proper permissions:
  1. Start SQL Server Enterprise Manager.
  2. Connect to the appropriate SQL server.
  3. Browse to the SQL Server\Security folder.
  4. Create a new logon profile.
  5. In the Create New Login dialog box:
    • On the General tab:
      • For Name, type:

        computer_name\AFSU_computer_name

      • For Default Database, type:

        InterchangeBTM

    • On the Database Access tab:
      • Give access permission to the InterchangeBTM database.
      • Specify public and db_owner as the roles for the InterchangeBTM database.
  6. Click OK to accept the changes.

STATUS

Microsoft has confirmed that this is a bug in the Microsoft products that are listed at the beginning of this article. The issue will be corrected in the next version of this product.

Modification Type:MajorLast Reviewed:6/25/2004
Keywords:kbfix kbprb KB316012