Users Receive a "Page Cannot Be Displayed" Error Message When They Use Outlook Web Access (315920)



The information in this article applies to:

  • Microsoft Small Business Server 2000
  • Microsoft BackOffice Server 2000
  • Microsoft Exchange 2000 Server

This article was previously published under Q315920
Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

After you upgrade from Small Business Server 4.5 to Small Business Server 2000, Outlook Web Access may not function properly. Users who attempt to use Outlook Web Access may receive a "Page cannot be displayed" error message. (This error message is equivalent to an HTPP 404 "File not found" error message.)

CAUSE

This issue may occur if the following registry key is not deleted during the Exchange upgrade process:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeWeb\Applications\Exchange

RESOLUTION

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.
To resolve this issue, delete only the Exchange subkey from the following registry key, and then restart the computer:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeWeb\Applications

WORKAROUND

To work around this issue, remove the Exchfilt.dll ISAPI filter from the default Web site. This causes Outlook Web Access to function properly.

NOTE: If you use this workaround, Exchange Conferencing Server does not work.

MORE INFORMATION

Another symptom of this issue is recorded in the Microsoft Internet Information Services (IIS) logs. If the Applications subkey is not deleted during the upgrade process, incoming Web requests for Outlook Web Access look similar to:

GET /exchange/USA/Default.htm

After a successful Exchange upgrade, so that this issue is not occurring, the Web request does not contain a "USA" entry. For example:

GET /exchange/

In the correct GET request, the "USA" language is not specified.

Modification Type:MinorLast Reviewed:5/2/2005
Keywords:kbenv kberrmsg kbprb kbUpgrade KB315920