OL2002: Attachments Are Not Sent When You Forward a Signed Message (315890)






This article was previously published under Q315890

SYMPTOMS

When you forward a signed message that includes an attachment, the recipient may not receive the attachment.

CAUSE

This problem may occur if the following three conditions are true when you forward a signed message with an attachment:
  • If your certificate security is set to High (requiring a password to use the certificate), and you receive a prompt for your password every time you send a signed message.
  • If you click Cancel when you receive the prompt for your password.
  • If you turn off (disabled) the Add digital signature to this message option in the Security Properties dialog box.

RESOLUTION

To resolve this problem, obtain the latest service pack for Microsoft Office XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

307841 OFFXP: How to Obtain the Latest Office XP Service Pack

The English-language version of this fix should have the following file attributes or later:
   Date         Time    Size       File name     
   -------------------------------------------------
   23-Jan-2002  20:36   2,557,416  Outlook.msp
   23-Jan-2002  21:08   3,913,216  Outlook_admin.msp
				
After the fix is installed, the following files will have the listed attributes or later:
   Date        Time      Version      Size       File name     
   ----------------------------------------------------------
   29-Nov-2001 00:21:29  10.0.3527.0     47,432  Recall.dll
   20-Dec-2001 17:44:00  10.0.3618.0     92,488  Outlmime.dll
   11-Jan-2002 13:59:19  10.0.3708.0    534,856  OutlCM.dll
   22-Jan-2002 23:32:22  10.0.3716.0    342,344  Exsec32.dll
   22-Jan-2002 23:32:25  10.0.3716.0  6,306,120  Outllib.dll

				

Administrative Information

If you are updating an administrative installation with the administration version of this fix, use the following information to update the administrative installation and network clients.

How to Update Administrative Installations

To update an administrative installation use a command line similar to the following

msiexec /a Admin Path\MSI File /p MSP path SHORTFILENAMES=1

where Admin Path is the path to your administrative installation point for Microsoft Office XP (for example, C:\OfficeXP),

where MSI File is the MSI database package for the Office XP product (for example, ProPlus.msi), and

where MSP path is the path to the administrative update for the fix (for example, c:\hotfixfiles\Outlook_admin.msp).

How to Update Network Clients

After you complete the administrative installation of the fix, update each network client. To deploy the update to the client workstations, use a command line similar to the following

msiexec /i Admin Path\MSI File REINSTALL=OUTLOOKFiles,OUTLOOKNonBootFiles REINSTALLMODE=vomus

where Admin Path is the path to your administrative installation point for Office XP (for example, C:\OfficeXP), and

where MSI File is the MSI database package for the Office XP product (for example, ProPlus.msi).

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Microsoft Office XP Service Pack 2 (SP-2).

Modification Type: Minor Last Reviewed: 7/28/2006
Keywords: kbbug kbfix kbOfficeXPPreSP2fix kbOfficeXPsp2fix kbHotfixServer kbQFE KB315890