PRB: Enterprise Services Components Do Not Flow from Managed Call Context (315883)



The information in this article applies to:

  • Microsoft Visual Studio .NET (2002), Professional Edition
  • Microsoft Enterprise Services (included with the .NET Framework) 1.0

This article was previously published under Q315883

SYMPTOMS

Items that you put in managed CallContext are frequently not propagated through a Microsoft Enterprise Service Call Graph.

CAUSE

ServicedComponent objects do not support information that flows in the managed CallContext at this time. If you call the CallContext.SetData() or the CallContext.SetHeaders() method to put items in the CallContext class before you call ServicedComponent methods, the CallContext items are frequently not available in the ServicedComponent methods.

STATUS

This behavior is by design.

MORE INFORMATION

To work around this issue, pass any information to your ServicedComponents in method parameters.

REFERENCES

319177 FIX: CallContext Objects Are Lost When You Create a New Serviced Component

Modification Type:MajorLast Reviewed:6/28/2004
Keywords:kbprb KB315883