SMS: Cannot Reinstall Inventory Components on Windows XP (315715)



The information in this article applies to:

  • Microsoft Systems Management Server 2.0

This article was previously published under Q315715
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

You cannot install the Systems Management Server (SMS) Software Inventory Client Agent on computers that are running Microsoft Windows XP. This problem occurs after you remove the client, and then reinstall it by using SMSMAN or 20clicln.bat. The following error message is logged in the Sinv32.log file:
ERROR 4 - Get SW Inventory Sites data failed !!

CAUSE

By default, registry key permissions are provided to the logged-on user and System accounts in Windows XP. To remove the SMS client and then install it again, the SMSClitoknacct& account is used. However, the account is deleted and re-created during this process, which changes its security identifier (SID). This affects the access control list (ACL) for the registry keys because the SID is different for the new account.

RESOLUTION

To resolve this problem, obtain the latest service pack for Microsoft Systems Management Server 2.0. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

288239 How to Obtain the Latest Systems Management Server 2.0 Service Pack

WORKAROUND

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
To work around this issue, remove the following SMS registry key:
  1. Start Registry Editor (Regedt32.exe).
  2. Delete the following registry key on all affected clients:

    HKEY_LOCAL_MACHINE\SOFTWARE\MICROSOFT\SMS\CLIENT

  3. Quit Registry Editor.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Microsoft Systems Management Server 2.0 Service Pack 5.

MORE INFORMATION

SMS 2.0 Service Pack 4 (SP4) adds explicit permissions for the local Administrators group and system account on hardware and software inventory Sites registry subkeys and the remote control Wuser32Initialized registry subkey.

This problem did not occur in Microsoft Windows 2000 or earlier versions of Windows because the default permissions that were created were assigned to the local Administrators group, in which the newly-created SMSClitoknacct& account is added as a member.

Modification Type:MinorLast Reviewed:9/30/2005
Keywords:kbHotfixServer kbQFE kbSMS200preSP5fix kbDiscovery kbBug kbenv kberrmsg kbfix kbsetup kbsms200preSP4fix KB315715