Newly created mailbox or distribution list is not displayed in the Global Address List (315531)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange 2000 Server
  • Microsoft Windows Small Business Server 2003, Premium Edition
  • Microsoft Windows Small Business Server 2003, Standard Edition

This article was previously published under Q315531

SYMPTOMS

If you create a new user mailbox or distribution list, the new object is not displayed in the Global Address List. Additionally, you cannot perform a checkname operation on the new object.

CAUSE

This issue may occur if you incorrectly set the filter on the default Global Address List. For example, this issue occurs if you base the filter on mail attributes that do not exist when the Recipient Update Service updates the objects. This is because mail attributes do not exist when the Recipient Update Service first updates the object. Therefore, the ShowInAddressBook attribute does not contain all address lists. This prevents the address lists from being displayed in the Global Address List at the client.

Note This issue may also occur if you incorrectly set the filter on other address lists that are listed under All Address Lists in Exchange System Manager. If the default filter has to be modified, make sure that you base your LDAP queries on attributes that exist before the Recipient Update Service tries to update the objects.

RESOLUTION

Warning If you use the ADSI Edit snap-in, the LDP utility, or any other LDAP version 3 client, and you incorrectly modify the attributes of Active Directory objects, you can cause serious problems. These problems may require you to reinstall Microsoft Windows 2000 Server, Microsoft Windows Server 2003, Microsoft Exchange 2000 Server, Microsoft Exchange Server 2003, or both Windows and Exchange. Microsoft cannot guarantee that problems that occur if you incorrectly modify Active Directory object attributes can be solved. Modify these attributes at your own risk.

To resolve this issue, start Exchange System Manager, open the default Global Address List properties, and then make sure that the Search filter is correct. The filter should look like the following filter:

(& (mailnickname=*) (| (&(objectCategory=person)(objectClass=user)(!(homeMDB=*))(!(msExchHomeServerName=*)))(&(objectCategory=person)(objectClass=user)(|(homeMDB=*)(msExchHomeServerName=*)))(&(objectCategory=person)(objectClass=contact))(objectCategory=group)(objectCategory=publicFolder) ))

If the filter does not match the preceding filter, set the filter again. To do so:
  1. Start ADSI Edit from Windows 2000 Support Tools.
  2. Expand the Configuration container.
  3. Expand CN=Configuration.
  4. Expand CN=Services.
  5. Expand CN=Microsoft Exchange.
  6. Expand CN=Exchange Organization Name.
  7. Expand CN=Address Lists Container.
  8. Expand CN=All Global Address Lists.
  9. Right-click CN=Default Global Address List and click Properties.
  10. Click the purportedSearch attribute in the Select property to view box.
  11. Paste the following filter in the Edit Attribute box:

    (& (mailnickname=*) (| (&(objectCategory=person)(objectClass=user)(!(homeMDB=*))(!(msExchHomeServerName=*)))(&(objectCategory=person)(objectClass=user)(|(homeMDB=*)(msExchHomeServerName=*)))(&(objectCategory=person)(objectClass=contact))(objectCategory=group)(objectCategory=publicFolder) ))

  12. Click Set, and then click OK.

MORE INFORMATION

This issue may also occur if you set the filter on other address lists that are listed under All Address Lists in Exchange System Manager incorrectly.

Modification Type:MinorLast Reviewed:4/25/2005
Keywords:kbprb KB315531