MS01-052: Clients with an Expired Temporary License May Be Unable to Connect to Terminal Services (315404)



The information in this article applies to:

  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Advanced Server SP2
  • Microsoft Windows 2000 Professional SP1
  • Microsoft Windows 2000 Professional SP2
  • Microsoft Windows 95
  • Microsoft Windows 98
  • Microsoft Windows 98 Second Edition
  • Microsoft Windows NT Workstation 4.0
  • Microsoft Windows NT Server 4.0
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional

This article was previously published under Q315404

SYMPTOMS

New Terminal Server clients, Terminal Services clients, or Remote Desktop Connection clients may connect to Terminal Services correctly, but some existing clients that could previously connect may be unable to connect. If an existing client cannot connect, the following error message may be displayed on the client computer:
Terminal Server has ended the connection
In all cases, clients can connect as if they were new clients if you delete the license from the client. For additional information about deleting licenses, click the article number below to view the article in the Microsoft Knowledge Base:

248430 How to Transfer Terminal Services CAL from One Computer to Another

CAUSE

If a client's temporary license expires and the license server that is contacted by the Terminal Services server is not the issuer of the client's temporary license, the license server does not upgrade the license to a permanent license. This is most likely to occur because the original issuer of the temporary license cannot be contacted by the Terminal Services server. This may occur because the license server has been rebuilt or is currently unavailable.

RESOLUTION

To resolve this problem, obtain the latest service pack for Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

260910 How to Obtain the Latest Windows 2000 Service Pack

The resolution for this problem is also included in Windows 2000 Security Rollup Package 1 (SRP1). For additional information about SRP1, click the article number below to view the article in the Microsoft Knowledge Base:

311401 Windows 2000 Security Rollup Package 1 (SRP1), January 2002

The fix for this issue is included in the following patch: You can also use this patch as a replacement for the licensing enhancements that are documented in the following Microsoft Knowledge Base article:

287687 Terminal Services Licensing Enhancements

STATUS

Microsoft has confirmed that this problem may cause a degree of security vulnerability in Microsoft Windows 2000. This problem was first corrected in Windows 2000 Service Pack 3.

MORE INFORMATION

The fix for this problem is server-side (on the license server). Because Terminal Services may potentially have a wide variety of clients that connect to it, it is not possible to list every affected client platform in this article. This may also affect clients running third-party operating systems or other Microsoft clients that may not be explicitly listed.

Modification Type:MinorLast Reviewed:12/20/2004
Keywords:kbbug kberrmsg kbfix kbSecurity kbTermServ kbWin2000PreSP3Fix kbWin2000sp3fix KB315404