"The Windows Installer Service Could Not Be Accessed" error message when you install a program in Windows XP (315353)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Office Excel 2003
  • Microsoft Office FrontPage 2003
  • Microsoft Office Outlook 2003
  • Microsoft Office PowerPoint 2003
  • Microsoft Office Publisher 2003
  • Microsoft Office Word 2003
  • Microsoft Office Professional Edition 2003
  • Microsoft Office Standard Edition 2003
  • Microsoft Office Student and Teachers Edition 2003
  • Microsoft Office Small Business Edition 2003
  • Microsoft Office Basic Edition 2003
  • Microsoft Office Access 2003

This article was previously published under Q315353
Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

When you try to install a program, such as Microsoft Plus! for Windows XP or Microsoft Office 2003, in Microsoft Windows XP, you may receive the following error message:
The Windows Installer Service could not be accessed.
This can occur if you are running Windows in safe
mode, or if the Windows Installer is not correctly
installed. Contact your support personnel for assistance.

CAUSE

This issue may occur when both the following conditions are true:
  • You are using Windows XP in Normal mode.
  • The Windows Installer Service that is included with Windows XP is unregistered or damaged.

RESOLUTION

To resolve this issue, follow these steps:
  1. Log on to your computer as an administrator.
  2. Click Start, and then click Run.
  3. In the Open box, type cmd, and then click OK.
  4. At the command prompt, type msiexec.exe /unregister, and then press ENTER.
  5. Type msiexec /regserver, and then press ENTER.
  6. Verify that the SYSTEM account has full control access permissions to the HKEY_CLASSES_ROOT hive in the Windows registry. In some cases, you may also have to add Administrator accounts. To do so:Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.
    1. Click Start, click Run, type regedit in the Open box, and then click OK.
    2. Click the following registry hive:

      HKEY_CLASSES_ROOT

    3. On the Edit menu, click Permissions.
    4. If SYSTEM is not listed in the Group or user names list, click Add, make sure that the local computer name appears in the From this location box, type system in the Enter the object names to select box, click Check Names, and then click OK.
    5. Click SYSTEM in the Group or user names list, and then select the Full Control check box under Allow in the Permissions for SYSTEM box.
    6. Click Apply, click OK, and then quit Registry Editor.
  7. Restart the computer. If the problem is not resolved, repair Windows XP. For more information about how to repair Windows XP, click the following article number to view the article in the Microsoft Knowledge Base:

    315341 How to perform an in-place upgrade (reinstallation) of Windows XP


Modification Type:MinorLast Reviewed:2/13/2006
Keywords:kbPubTypeKC kbtshoot kberrmsg kbprb KB315353